Ask Your Question
0

Rosdep Init cannot download default sources

asked 2019-02-20 17:23:21 -0600

jtroll gravatar image

updated 2019-02-20 19:30:03 -0600

jayess gravatar image

Just upgraded to 18.04 which required uninstalling ROS from 16.04 (or was I the only one with this issue?). Installing ROS Melodic and I cannot get "sudo rosdep init" to run:

~$ sudo rosdep init
ERROR: cannot download default sources list from:
https://raw.githubusercontent.com/ros/rosdistro/master/rosdep/sources.list.d/20-default.list
Website may be down.

I see that something about the Github URLs was updated in 0.15.1 ROSDEP ( https://github.com/ros-infrastructure... ) and I'm wondering if there's some issue that is not my own? I've tried removing rosdep and reinstalling with no success.

edit retag flag offensive close merge delete

Comments

With a browser I am able to get to each of the URLS listed in: https://raw.githubusercontent.com/ros...

jtroll gravatar imagejtroll ( 2019-02-22 06:41:28 -0600 )edit

This file ( https://raw.githubusercontent.com/ros... ) states:

gbp-repos: ? You must update to a newer rosdep version by calling..sudo apt-get update && sudo apt-get install python-rosdep (make sure to uninstall the pip version on Ubuntu)

Is that my issue?

jtroll gravatar imagejtroll ( 2019-02-22 06:42:27 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2019-02-25 09:13:59 -0600

jtroll gravatar image

I finally got past this, thank goodness. After lots of reading and hacking and try-try-trying again, there are a two things I did to correct this that I want to point out for the community:

  1. I manually installed the "DigiCert SHA2 Secure Server" certificate with instructions from this site: https://bugs.launchpad.net/ubuntu/+source/ca-certificates/+bug/1795242

This seems necesarry to talk to raw.github.com . That did not fix everything by itself, but seemed to be necessary based on connectivity issues I was having. Not sure why this wasn't already installed, but I don't know anything about certificates. I don't know if this was the issue.

What then ultimately fixed it for me was this:

  1. Editing c_rehash lines 15 and 16 to point to "/usr/local/ssl" and copying certificates to that location, which has something to do with making "wget work as before upgrade to Ubuntu 18.04". I found those instructions at this site: https://superuser.com/questions/13872...
edit flag offensive delete link more

Comments

I'm using Ubuntu 14.04 and it still doesn't work , it still cannot connect to raw.github.com And I don't have the problem that stated in superuser site.

noone gravatar imagenoone ( 2019-07-06 23:30:54 -0600 )edit
1

answered 2019-02-20 19:26:48 -0600

tfoote gravatar image

There's a lot of similar questions: https://www.google.com/search?q=rosde...

This is most commonly an issue with network connectivity.

You're having issues with the new url so it's not related to the recent update to rosdep for the github url change.

You should validate that you can get to that url by default.

As for the upgrade yes, you cannot keep the same ROS version installed between 16.04 and 18.04 as they are not both supported by a single ROS distro. See here for target platforms: http://www.ros.org/reps/rep-0003.html...

edit flag offensive delete link more
-1

answered 2019-11-05 20:51:48 -0600

toby gravatar image
edit flag offensive delete link more

Comments

Please do not post link-only answers. They are of little value when the site you link to disappears.

Moreover: the site you link to is in Chinese. ROS Answers is an English speaking site.

Please post an English summary here to make your answer stand on its own.

gvdhoorn gravatar imagegvdhoorn ( 2019-11-06 01:11:22 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-02-20 17:23:21 -0600

Seen: 2,078 times

Last updated: Nov 05