Ask Your Question
2

KeyError: '10' when running rosdep install on Linux Mint 10 machine

asked 2011-03-30 00:52:29 -0500

Toni gravatar image

updated 2014-01-28 17:09:27 -0500

ngrennan gravatar image

Hello!

I started ROS on Linux Mint in a Virtual Box. Since the virtual Linux was very slow, I installed the full Linux Mint and restarted the Tutorial in the new Linux. Unfortunately when I arrived at the 3rd chapter and tried to install the turtlesim the following error happend:

/opt/ros/diamondback/stacks/ros_tutorials/turtlesim $ rosdep install turtlesim
Traceback (most recent call last):
  File "/opt/ros/diamondback/ros/bin/rosdep", line 35, in <module>
    sys.exit(rosdep.main())
  File "/opt/ros/diamondback/ros/tools/rosdep/src/rosdep/main.py", line 124, in main
    r = core.Rosdep(verified_packages, robust=options.robust)
  File "/opt/ros/diamondback/ros/tools/rosdep/src/rosdep/core.py", line 296, in __init__
    self.osi = roslib.os_detect.OSDetect(os_list)
  File "/opt/ros/diamondback/ros/core/roslib/src/roslib/os_detect.py", line 479, in __init__
    self.detect_os()
  File "/opt/ros/diamondback/ros/core/roslib/src/roslib/os_detect.py", line 498, in detect_os
    self._os_version = os_class.get_version()
  File "/opt/ros/diamondback/ros/tools/rosdep/src/rosdep/debian.py", line 124, in get_version
    return self.version_map[self.mint_detector.get_version()]
KeyError: '10'

If somebody has an Idea on how to solve it, I would be very happy for any input! I already reinstalled ROS and uninstalled the Virtual box, but it is still not working...

Thanks a lot

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
3

answered 2011-03-30 09:16:30 -0500

tfoote gravatar image

Rosdep doesn't support Mint 10 at the moment. There is a patch to be applied in ticket 3404 thanks to flofra.

edit flag offensive delete link more

Comments

1

answered 2011-03-30 03:39:13 -0500

updated 2011-03-30 03:40:57 -0500

Seems like ROS has problems detecting Linux Mint. Maybe this page will help you as a starting point.

edit flag offensive delete link more
0

answered 2011-06-12 21:16:10 -0500

Fulin gravatar image

I'm a newbie to both ROS and Linux.

Can anyone give a little details "step by step" on how to implement the patching?

Thank you in advance!

edit flag offensive delete link more

Comments

It is not specific to ros. http://linux.die.net/man/1/patch and (you need to append the closing parenthesis to the link, it isn't recognized as part of the url) http://en.wikipedia.org/wiki/Patch_(Unix)
Felix Endres gravatar image Felix Endres  ( 2011-06-13 21:32:07 -0500 )edit
Thank you very much! I did the following
Fulin gravatar image Fulin  ( 2011-06-14 02:09:35 -0500 )edit
sudo patch -p0 <debian.py_mint10.patch and rosdep install works well on my mint 10
Fulin gravatar image Fulin  ( 2011-06-14 02:10:15 -0500 )edit
You are wellcome. It would be best, if you edited your question to contain the answer too. It's more visible there than in the comments
Felix Endres gravatar image Felix Endres  ( 2011-06-14 05:35:10 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-03-30 00:52:29 -0500

Seen: 584 times

Last updated: Jun 12 '11