Ask Your Question
2

Does ROS currently install on Mint 13?

asked 2012-10-10 17:36:05 -0600

nckswt gravatar image

updated 2014-01-28 17:13:54 -0600

ngrennan gravatar image

I'm trying to install ROS on a fresh Mint 13 install, and after following the debian install guide, I get stuck at step 1.5.

Rosdep -a gives the following output:

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/rosdep2/main.py",

line 111, in rosdep_main exit_code = _rosdep_main(args) File "/usr/local/lib/python2.7/dist-packages/rosdep2/main.py", line 232, in _rosdep_main return _package_args_handler(command, parser, options, args) File "/usr/local/lib/python2.7/dist-packages/rosdep2/main.py", line 255, in _package_args_handler lookup = _get_default_RosdepLookup(options) File "/usr/local/lib/python2.7/dist-packages/rosdep2/main.py", line 102, in _get_default_RosdepLookup verbose=options.verbose) File "/usr/local/lib/python2.7/dist-packages/rosdep2/sources_list.py", line 477, in create_default matcher = DataSourceMatcher.create_default(os_override=os_override) File "/usr/local/lib/python2.7/dist-packages/rosdep2/sources_list.py", line 228, in create_default os_name, os_version, os_codename = os_detect.detect_os() File "/usr/local/lib/python2.7/dist-packages/rospkg/os_detect.py", line 404, in detect_os raise OsNotDetected("Could not detect OS, tried %s"%attempted) OsNotDetected: Could not detect OS, tried ['ubuntu', 'rhel', 'osx', 'opensuse', 'mint', 'gentoo', 'freebsd', 'fedora', 'debian', 'cygwin', 'arch']

I've tried running rosdep install -a --os=mint:maya, but here's a sample of what I get in return:

ERROR: the following packages/stacks could not have their

rosdep keys resolved to system dependencies: rosconsole: Unsupported OS [mint] image_view: Unsupported OS [mint] carrot_planner: Missing resource pcl ROS path [0]=/opt/ros/fuerte/share/ros ROS path [1]=/home/nick/ros/navigation ROS path [2]=/home/nick/ros/diagnostics

Along with a ton more "Unsupported OS [mint]" issues. My question is: does a workaround exist, or can I simply not install ROS on my Mint 13 system?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
5

answered 2012-10-10 18:26:02 -0600

jbohren gravatar image

For the first error, there might be a bug in rospkg. You might want to file a ticket on it here: https://github.com/ros/rospkg/issues

For the second, it looks like there are only a few packages that are missing dependencies. You can try adding the appropriate deps and testing it out / contributing it via these instructions: http://ros.org/doc/api/rosdep2/html/contributing_rules.html

edit flag offensive delete link more
4

answered 2012-10-11 05:58:42 -0600

Tully gravatar image

As a workaround you can set your os to the corresponding ubuntu version as Mint is very closely related to ubuntu. I'm not sure which codename maya maps to but do something like this: --os=ubuntu:precise

edit flag offensive delete link more

Comments

Changing the OS as Tully suggested seems to be working for me at the moment.

pvfjr1 gravatar imagepvfjr1 ( 2013-09-30 20:27:48 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-10 17:36:05 -0600

Seen: 1,782 times

Last updated: Oct 11 '12