ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

slam_toolbox offline slam

asked 2022-07-01 08:42:58 -0600

MrOCW gravatar image

updated 2022-07-01 09:14:54 -0600

Hi, with reference to https://github.com/ros-drivers/ros2_o... I am unable to visualize the pointcloud in rviz if my fixed frame is not base_link or its children.... I went on to attempt recording a bag and tried launching offline slam but I get this chunk of messages in terminal:

[sync_slam_toolbox_node-1] [INFO] [1656682550.264695902] [slam_toolbox]: Message Filter dropping message: frame 'os1_lidar' at time 5867.116 for reason 'the timestamp on the message is earlier than all the data in the transform cache'

Here is the bag: https://drive.google.com/file/d/1vKoF...

odom->base_link->everything else looks good... odom is being published by robot_localization

My TF Tree:

image description

EDIT 1:

I was able to figure out that the timestamps on the lidar vs the other topics were way off: image description

I've set timestamp_mode: TIME_FROM_PTP_1588

Am i not supposed to set to this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-07-01 13:41:29 -0600

The most immediate thing I see is that your node on the left is using simulation time (59XX) while the bottom node on the right is using wall time (165xxxxxxx) so your error makes sense that its having issues since they're not referencing the same time source.

I think you need to use sim time in those nodes as well.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2022-07-01 08:42:58 -0600

Seen: 75 times

Last updated: Jul 01