ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

octovis for ros-electric

asked 2012-07-27 02:55:56 -0600

Sudhan gravatar image

updated 2014-01-28 17:13:10 -0600

ngrennan gravatar image

How to install octovis for ros-electric?

I tried $ sudo apt-get install ros-electric-octomap-visualization. But it reported can't locate the package.

Then I read some of the discussions in ros.answers and tried from $ svn co octomap and compiled using commands cmake and make

after that in the terminal I typed command $ ocotovis It says command not found.

Any solutions?

Thanks in advance

Updated: Also, while compiling I see the compilation is successful. I can see files inside folder build, bin and lib. Though, I am unable to open the octovis GUI. I used the above command to open that.

edit retag flag offensive close merge delete


Did you check if it's build in a subdirectory like bin/?

dornhege gravatar image dornhege  ( 2012-07-27 03:02:32 -0600 )edit

Yes, it's built in the subdirectory. Though, it says command not found

Sudhan gravatar image Sudhan  ( 2012-07-29 21:10:27 -0600 )edit

So, did you execute the binary in bin/octovis or just type octovis?

dornhege gravatar image dornhege  ( 2012-07-29 23:46:43 -0600 )edit

see answer.

dornhege gravatar image dornhege  ( 2012-07-30 01:18:28 -0600 )edit

yes, I got it. Thank you..

Sudhan gravatar image Sudhan  ( 2012-07-30 01:20:44 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2012-07-30 02:02:27 -0600

dornhege gravatar image

If the file is in bin/octovis relative to your directory, execute bin/octovis.

edit flag offensive delete link more

Question Tools


Asked: 2012-07-27 02:55:56 -0600

Seen: 465 times

Last updated: Jul 30 '12