Ask Your Question
0

Problems building and using OCTOMAP with RGBDSLAM

asked 2012-02-03 21:09:32 -0500

Mike Moore gravatar image

updated 2014-01-28 17:11:16 -0500

ngrennan gravatar image

Hi again folks (I'm back after a short stint on another project)

After some work I managed to get RGBDSLAM running nicely (discovering the long way round that it does NOT work on a VMWare Virtual Machine) and am now struggling to build and use OCTOMAPS.

I have gone through all the RGBDSLAM information and tons of references in ROS Answers without success. There are however some rather different instructions of how to achieve this so, please can you clarify which is the most effective and up to date.

RGBDSLAM is working fine so, here is what Ive done thus far:

FIRST ATTEMPT (as per section 4.1 of http://www.ros.org/wiki/rgbdslam#Octomaps)

1) GET SOURCE: Checked out latest OCTOMAP experimental code

svn co http://alufr-ros-pkg.googlecode.com/svn/branches/octomap_mapping-experimental/

2) BUILD: Built experimental OCTOMAP Server

cd ros/octomap_mapping-experimental/build/

cmake ..

make

(Seemed to complete with no errors or warnings - perhaps Ive done this wrong?)

3) LAUNCH BY ITSELF: Launched OCTOMAP server by itself to test

roslaunch rgbdslam octomap_server.launch

But I get the following error (perhaps its because RGBDSLAM isn't running):

started core service [/rosout] ERROR: cannot launch node of type [octomap_server/octomap_server_node]: Cannot locate node of type [octomap_server_node] in package [octomap_server]

5) LAUNCH AFTER RGBDSLAM So, as per the instructions I first launched RGBDSLAM using:

roslaunch rgbdslam kinect+rgbdslam.launch

I then captured a scene then tried to launch the OCTOMAP server (obviously using a new Terminal - is this correct?) with:

roslaunch rgbdslam octomap_server.launch

but again I get the following error:

core service [/rosout] found ERROR: cannot launch node of type [octomap_server/octomap_server_node]: Cannot locate node of type [octomap_server_node] in package [octomap_server] No processes to monitor shutting down processing monitor... ... shutting down processing monitor complete

4) CONFIGURATION: I made the following modifications but they didn't help:

Edit (a copy of) octomap_server/launch/octomap_mapping.launch such that the mapping from cloud_in goes to /rgbdslam/batch_clouds and the value of frame_id is "openni_camera"

Are these changes necessary? Are there more that should be made?

SECOND ATTEMPT (as per section 4 of http://www.ros.org/wiki/rgbdslam/evaluation#Octomapping_Requirements)

1) SOURCE: Checked out latest OCTOMAP evaluation code

svn co https://alufr-ros-pkg.googlecode.com/svn/branches/octomap_mapping_color ~/ros/octomap_mapping_color
svn co https://code.ros.org/svn/wg-ros-pkg/stacks/motion_planning_common/trunk ~/ros/motion_planning_common

2) BUILD: Built evaluation OCTOMAP Server

rosmake motion_planning_common
rosmake --rosdep-install octomap_mapping_color

Unfortunately NEITHER of these currently build without errors so I was unable to proceed here too.


So, please could someone clarify, step by step, how I go about setting up and run OCTOMAPS with RGBDSLAM.

Many thanks (and sorry I keep struggling with these seemingly straightforward things :-))

edit retag flag offensive close merge delete

Comments

1
It looks like the OCTOMAPS build has some missing dependencies on qt4-opengl and qglviewer-qt4 so I tried installing the libqglviewer-qt4-2 and libqglviewer-qt4-dev but they haven't cleared up the build yet. Even rosmake --rosdep-install octomap_mapping-experimental doesn't work...hmmm
Mike Moore gravatar imageMike Moore ( 2012-02-04 00:03:56 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2012-02-04 00:19:29 -0500

jwrobbo gravatar image

It sounds like octomap hasn't built properly - look in the bin folder of your octomap_server directory and there should be octomap_saver and octomap_server_node.

Do you need the experimental version? Have you just tried: sudo apt-get install ros-electric-octomap-mapping ros-electric-octomap-visualization ?

If you're using the launch files in rgbdslam you shouldn't need to alter the ones in the octomap stack itself. Cloud_in going to /rgbdslam/batch_clouds and frame_id as /map should be fine.

I found I had to add: < param name="base_frame_id" value="/openni_rgb_optical_frame" /> to the octomap server parameters or I got tf errors.

edit flag offensive delete link more

Comments

Thanks jwroobo, experimental for color OCTOMAPS. Definitely isnt building properly as I still get these missing dep. errors: "Failed to find rosdep qglviewer-qt4 for package octovis on OS:ubuntu version:oneiric" and "Failed to find rosdep qt4-opengl for package octovis on OS:ubuntu version:oneiric"?
Mike Moore gravatar imageMike Moore ( 2012-02-04 02:48:19 -0500 )edit
Have a look at the file "/opt/ros/electric/stacks/octomap_visualization/rosdep.yaml" and install the mentioned packages manually using "apt-get install <package-name>"
Felix Endres gravatar imageFelix Endres ( 2012-02-07 03:18:12 -0500 )edit
0

answered 2012-02-07 03:31:04 -0500

Regarding the experimental stack of the octomap_server, I found there is a big problem:

The Makefile downloads a tarball directly from the computer of the author of the color-octomaps. However, he has recently graduated and left the university, thus the computer with the tarball has been shut down...

The newest stable release of the octomapping library (not the ros package though) should support colored octomaps now, so somehow it should be possible to transition to that release. I'll have a look into it, but it could take a while.

Sorry for the inconvenience.

edit flag offensive delete link more

Comments

Hi Felix, have you worked it out right now? As I still come across with the same problem.

Lili Meng gravatar imageLili Meng ( 2012-08-27 14:21:50 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2012-02-03 21:09:32 -0500

Seen: 2,873 times

Last updated: Feb 07 '12