Ask Your Question
1

rgbdslam with ROS fuerte installed

asked 2012-07-16 23:33:36 -0500

dragonfly90 gravatar image

updated 2014-01-28 17:13:02 -0500

ngrennan gravatar image

Hi, I am using rgbdslam on a Ubuntu 11.10 machine, with ROS fuerte installed. I follow the tutorial(http://www.ros.org/wiki/rgbdslam), but when I type:

dong@dong-Inspiron-N5110:~/fuerte_workspace/sandbox$ rosdep install rgbdslam

there is a bug:

    ERROR: the following packages/stacks could not have their rosdep keys resolved
    to system dependencies:

    rgbdslam: Missing resource eigen

    ROS path [0]=/opt/ros/fuerte/share/ros

    ROS path [1]=/home/dong/fuerte_workspace/sandbox

    ROS path [2]=/home/dong/ros

    ROS path [3]=/home/dong/ros

    ROS path [4]=/opt/ros/fuerte/share

    ROS path [5]=/opt/ros/fuerte/stacks

Is rgbdslam not available for fuerte? How can I make it work?

By following Allenh1's answer, I solved a question but encounter another question:

dong@dong-Inspiron-N5110:~$ rosdep install rgbdslam

    ERROR: the following packages/stacks could not have their rosdep keys resolved
    to system dependencies:

    rgbdslam: Cannot locate rosdep definition for [gl2ps]

I don't know why. rosmake don't work too.

I Use this command to install the package:

    sudo apt-get install libgl2ps-dev libgl2ps0

but it doesn't work. there is still

the error above.
    the rosmake(with complete information) error is:


dong@dong-Inspiron-N5110:~/fuerte_workspace/sandbox/rgbdslam$ rosmake rgbdslam


  [ rosmake ] rosmake starting...                                                 
[ rosmake ] Packages requested are: ['rgbdslam']                                
[ rosmake ] Logging to directory /home/dong/.ros/rosmake/rosmake_output-20120727-110708
[ rosmake ] Expanded args ['rgbdslam'] to:
['rgbdslam']                         
[rosmake-0] Starting >>> bullet [ make ]                                        
[rosmake-0] Finished <<< bullet ROS_NOBUILD in package bullet                   
[rosmake-0] Starting >>> geometry_msgs [ make ]                                 
[rosmake-0] Finished <<< geometry_msgs  No Makefile in package geometry_msgs    
[rosmake-0] Starting >>> sensor_msgs [ make ]                                   
[rosmake-1] Starting >>> roslang [ make ]                                       
[rosmake-2] Starting >>> rosconsole [ make ]                                    
[rosmake-0] Finished <<< sensor_msgs  No Makefile in package sensor_msgs        
[rosmake-0] Starting >>> angles [ make ]                                        
[rosmake-3] Starting >>> rostest [ make ]                                       
[rosmake-2] Finished <<< rosconsole  No Makefile in package rosconsole          
[rosmake-2] Starting >>> roswtf [ make ]                                        
[rosmake-0] Finished <<< angles ROS_NOBUILD in package angles                   
[rosmake-1] Finished <<< roslang  No Makefile in package roslang                
[rosmake-1] Starting >>> roscpp [ make ]                                        
[rosmake-0] Starting >>> rospy [ make ]                                         
[rosmake-2] Finished <<< roswtf  No Makefile in package roswtf                  
[rosmake-3] Finished <<< rostest  No Makefile in package rostest                
[rosmake-3] Starting >>> message_filters [ make ]                               
[rosmake-2] Starting >>> g2o [ make ]                                           
[rosmake-0] Finished <<< rospy  No Makefile in package rospy                    
[rosmake-1] Finished <<< roscpp  No Makefile in package roscpp                  
[rosmake-3] Finished <<< message_filters  No Makefile in package message_filters
[rosmake-0] Starting >>> std_msgs [ make ]                                      
[rosmake-1] Starting >>> rosbag [ make ]                                        
[rosmake-3] Starting >>> tf [ make ]                                            
[rosmake-1] Finished <<< rosbag  No Makefile in package rosbag                  
[rosmake-1] Starting >>> rosbuild [ make ]                                      
[rosmake-3] Finished <<< tf ROS_NOBUILD in package tf                           
[rosmake-0] Finished <<< std_msgs  No Makefile in package std_msgs              
[rosmake-0] Starting >>> pcl [ make ]                                           
[rosmake-3] Starting >>> roslib [ make ]                                        
[rosmake-1] Finished <<< rosbuild  No Makefile in package rosbuild              
[rosmake-0] Finished <<< pcl  No Makefile in package pcl                        
[rosmake-3] Finished <<< roslib  No Makefile in package roslib                  
[rosmake-0] Starting >>> smclib [ make ]                                        
[rosmake-1] Starting >>> rosservice [ make ]                                    
[rosmake-1] Finished <<< rosservice  No Makefile in package rosservice          
[rosmake-1] Starting >>> dynamic_reconfigure [ make ]                           
[rosmake-1] Finished <<< dynamic_reconfigure ROS_NOBUILD in package dynamic_reconfigure
[rosmake-1] Starting >>> common_rosdeps [ make ]                                
[rosmake-3] Starting >>> pluginlib [ make ]                                     
[rosmake-1] Finished <<< common_rosdeps ROS_NOBUILD in package common_rosdeps   
[rosmake-1] Starting >>> bond [ make ]                                          
[rosmake-0] Finished <<< smclib ROS_NOBUILD in package smclib                   
[rosmake-1] Finished <<< bond ROS_NOBUILD in package bond                       
[rosmake-1] Starting >>> opencv2 [ make ]                                       
[rosmake-3] Finished <<< pluginlib ROS_NOBUILD in package pluginlib             
[rosmake-0 ...
(more)
edit retag flag offensive close merge delete

Comments

by following allenh1's answer, I solved a question but encounter another question:

dragonfly90 gravatar imagedragonfly90 ( 2012-07-19 03:18:52 -0500 )edit
1

Hm... Those are the two packages you are failing to meet the dependencies for... I'd like to see the error from rosmake.

allenh1 gravatar imageallenh1 ( 2012-07-23 04:28:28 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
3

answered 2012-07-18 05:59:42 -0500

allenh1 gravatar image

updated 2012-07-19 04:01:26 -0500

Here's what I did to make it work:

Change the manifest.xml to the following:

<package>
  <description brief="SLAM on RGBD Data">
    This package can be used to register the point clouds from RGBD sensors such as the kinect or stereo cameras.
    The rgbdslam node can be connected easily to an octomap_server node to create a memory-efficient 3D map.
  </description>
  <author>Felix Endres, Juergen Hess, Nikolas Engelhard</author>
  <license>GPL v3</license>
  <review status="unreviewed" notes=""/>
  <url>http://ros.org/wiki/rgbdslam</url>
  <depend package="tf"/>
  <depend package="g2o"/>
  <depend package="pcl"/>
  <depend package="rospy"/>
  <depend package="roscpp"/>
  <depend package="rosbag"/>
  <depend package="pcl_ros"/>
  <!--depend package="opencv2"/-->
  <depend package="cv_bridge"/>
  <depend package="sensor_msgs"/>
  <!--depend package="openni_camera"/-->
  <depend package="geometry_msgs"/>
  <depend package="visualization_msgs"/>
  <rosdep name="opengl"/>
  <rosdep name="qt4"/>
  <rosdep name="eigen"/>
  <rosdep name="libglew"/>
  <rosdep name="libdevil"/>
  <rosdep name="gsl-dev"/>
  <rosdep name="gl2ps"/>
  <export>
    <rosdoc config="rosdoc.yaml" />
    <nodelet plugin="${prefix}/nodelet_plugins.xml" />
    <cpp cflags="-I${prefix}/srv_gen/cpp"/>
 </export>
</package>

This makes the eigen library known as a system dependency, not a ros package.


If you receive the error below, then you need to install a package.

ERROR: the following packages/stacks could not have their rosdep keys resolved
to system dependencies:

rgbdslam: Cannot locate rosdep definition for [gl2ps]

Use this command to install the package:

sudo apt-get install libgl2ps-dev libgl2ps0
edit flag offensive delete link more

Comments

1

How about you go to the root of the rgbdslam directory and do a git pull? Maybe code isnoutdated. If you just downloaded it, Check the cmake file. If it doesn't work, list the build log.

allenh1 gravatar imageallenh1 ( 2012-07-24 01:56:02 -0500 )edit

I edited the manifest, which fixed the issue with eigen, but now I'm getting an error about siftgpu CMake Error at CMakeLists.txt:103 (MESSAGE): SiftGPU cannot be compiled. Returned: 2

jerdman gravatar imagejerdman ( 2012-07-25 09:38:57 -0500 )edit

I edited the manifest, which fixed the issue with eigen, but now I'm getting an error about siftgpu

jerdman gravatar imagejerdman ( 2012-07-25 09:39:00 -0500 )edit
1

I edited the manifest, which fixed the issue with eigen, but now I'm getting an error about siftgpu

jerdman gravatar imagejerdman ( 2012-07-25 09:39:03 -0500 )edit

As per me you need a whole lot of other stuff just to use siftgpu. You can disable this feature(only an addon) by editing first line of CMakeList --- set(USE_SIFT_GPU 0) and try to build the rgbdslam if it succeeds please let me know

gpsinghsandhu gravatar imagegpsinghsandhu ( 2012-07-28 05:02:02 -0500 )edit
1

answered 2012-07-31 09:20:48 -0500

Hi Guys, there will be no "official" fuerte support until (at least) September due to the time constraints of the main developer (me). However, I would appreciate if someone who has it working, could describe the necessary steps on ros.org, e.g. here, and link to it from the rgbdslam page. I would also gladly accept a patch and turn it into a branch in the svn repository.

edit flag offensive delete link more
0

answered 2012-07-17 20:29:53 -0500

prince gravatar image

Did you installed eigen? In ROS Fuerte , Eigen and some others [read at link ] are independent libraries, no longer ros packages.

Please read http://ros.org/wiki/eigen for proper modifications to CMakeLists.txt

This shall resolve eigen lib dependency problem.

edit flag offensive delete link more

Comments

1

you doesn't need to install eigen. Only if you use diamondback, you need to install eigen. Considering, ROS Fuerte, goto "manifest.xml". Then, delete <depend package="eigen"/> and add <rosdep name="eigen"/> and also within the export (loop) add line as shown in the link http://ros.org/wiki/eigen.

Sudhan gravatar imageSudhan ( 2012-07-19 03:19:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-07-16 23:33:36 -0500

Seen: 4,432 times

Last updated: Aug 13 '12