ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

rosmake: error: no such option: --rosdep-install

asked 2012-07-23 11:03:58 -0500

updated 2012-07-23 12:28:37 -0500

joq gravatar image

Hi, I found there's something wrong with the installation of openni_kinect as I followed this website:

But when I typed rosmake openni_kinect --rosdep-install in the terminal of Ubuntu12.04, it displays rosmake: error: no such option: --rosdep-install. I have already checked on the internet, the answer seems to be

I have tried but it still doesn't work!!!Looking for help!!!! Thank you so much!


edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2012-07-23 12:22:03 -0500

it seems that I should call rosdep install and rosmake seperately in fuerte: After I type rosdep install openni_kinect rosmake openni_kinect

rather than rosmake openni_kinect --rosdep-install in the terminal.

It finally works!!!

edit flag offensive delete link more



This is correct. The rosmake --rosdep-install option is no longer available in Fuerte. Use an explicit rosdep install command, instead.

joq gravatar image joq  ( 2012-07-23 12:27:53 -0500 )edit

answered 2012-07-23 11:12:13 -0500

allenh1 gravatar image

At the bottom of the install page for fuerte, you find these instructions:

sudo apt-get install python-setuptools python-pip

sudo easy_install -U rosinstall vcstools rosdep

After you run this, you will have rosdep. If you are on Ubuntu, you should be able to install openni_kinect with your package manager.

sudo apt-get install ros-fuerte-openni-kinect
edit flag offensive delete link more

Question Tools


Asked: 2012-07-23 11:03:58 -0500

Seen: 5,750 times

Last updated: Jul 23 '12