Ask Your Question
0

rosdep fails to find libeigen3-dev on debian:squeeze

asked 2014-02-18 12:56:11 -0500

dave.peacock gravatar image

updated 2016-10-24 08:59:24 -0500

ngrennan gravatar image

Hi all,

Trying to build the 'robot' variant under debian:squeeze, having some trouble with this libeigen3-dev.

libeigen3-dev is listed for jessie, sid, and wheezy, but not for squeeze. Which makes sense as the package is not officially supported for squeeze. There is a supported. libeigen2-dev.

I was able to install from a downloaded .deb package (eg wget from ftp.us.debian.org , with libeigen3-dev_3.1.0-1_i386.deb or _armel.deb or whatever), this seems to have installed fine but i haven't got as far as testing the build since there are still other missing/problematic dependencies. But maybe someone will have an answer before i go much further with the others.

many thanks dave

edit retag flag offensive close merge delete

Comments

So what exactly is the question?

demmeln gravatar image demmeln  ( 2014-02-18 13:07:47 -0500 )edit

Ha, good question. I guess I was asking "Is installing libeigen3-dev manually the right thing to do on debian:squeeze", ahendrix's answer is sufficient for me, and hopefully this helps others running into the same or similar problems, but maybe squeeze is too old for a lot of hydro stuff

dave.peacock gravatar image dave.peacock  ( 2014-02-18 13:30:25 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-02-18 13:19:30 -0500

ahendrix gravatar image

It sounds like you're heading in the right direction by finding a libeigen3-dev to use. I suspect most of the code that uses eigen won't be backwards-compatible to older versions of eigen.

It sounds like you can manually tell rosdep that libeigen3 is installed according to https://github.com/ros-infrastructure...

edit flag offensive delete link more

Comments

Thanks, looks like the manual install worked, but link will prove useful for some other deps. But maybe robot variant is too much to ask of squeeze, geometry stack causing more grief. REP-131 suggests variants were getting phased out as of groovy, maybe should be using metapackages instead.

dave.peacock gravatar image dave.peacock  ( 2014-02-18 13:37:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-02-18 12:56:11 -0500

Seen: 290 times

Last updated: Feb 18 '14