Ask Your Question
1

unmet dependency on eigen for vision-opencv, now can't install or upgrade any fuerte packages

asked 2012-08-29 10:11:21 -0500

Bob Dean gravatar image

updated 2012-08-29 16:55:38 -0500

joq gravatar image

I tried to install vision-opencv today, and get failed dependencies due to a newer version of eigen3 (actually orocos depends on eigen, and geometry depends on orocos, and then vision-opencv depends on geometry). how can i resolve this? uninstalling eigen does not help as I get the same error. I tried uninstalling fuerte, but now cannot reinstall fuerte due to the same error.

[rdean@RCTA-HSS81P1 impl]$ sudo apt-get install ros-fuerte-vision-opencv

Reading package lists... 0%

Reading package lists... 100%

Reading package lists... Done

Building dependency tree... 0%

Building dependency tree... 0%

Building dependency tree... 50%

Building dependency tree... 50%

Building dependency tree

Reading state information... 0%

Reading state information... 0%

Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: ros-fuerte-vision-opencv: Depends: ros-fuerte-geometry (= 1.8.2-s1344793447~lucid) but it is not going to be installed Depends: ros-fuerte-orocos-kinematics-dynamics (= 0.2.3-s1344793277~lucid) but it is not going to be installed E: Broken packages [rdean@RCTA-HSS81P1 impl]$ sudo apt-get install ros-fuerte-orocos-kinematics-dynamics

Reading package lists... 0%

Reading package lists... 100%

Reading package lists... Done

Building dependency tree... 0%

Building dependency tree... 0%

Building dependency tree... 50%

Building dependency tree... 50%

Building dependency tree

Reading state information... 0%

Reading state information... 0%

Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: ros-fuerte-orocos-kinematics-dynamics: Depends: libeigen3-dev (= 3.0.1-1+ros4~lucid) but 3.0.2-3+lucid1 is to be installed E: Broken packages [rdean@RCTA-HSS81P1 impl]$ sudo apt-get install -f ros-fuerte-orocos-kinematics-dynamics

Reading package lists... 0%

Reading package lists... 100%

Reading package lists... Done

Building dependency tree... 0%

Building dependency tree... 0%

Building dependency tree... 50%

Building dependency tree... 50%

Building dependency tree

Reading state information... 0%

Reading state information... 0%

Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: ros-fuerte-orocos-kinematics-dynamics: Depends: libeigen3-dev (= 3.0.1-1+ros4~lucid) but 3.0.2-3+lucid1 is to be installed E: Broken packages [rdean@RCTA-HSS81P1 impl]$

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-09-16 18:58:26 -0500

tfoote gravatar image

This looks like the repo got into an inconsistent state. It should be cleared up by now?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-08-29 10:11:21 -0500

Seen: 448 times

Last updated: Sep 16 '12