Ask Your Question
0

rviz error on turtlebot laptop(Asus Eee PC 1215B)

asked 2012-07-08 16:01:50 -0600

moyashi gravatar image

updated 2012-07-09 16:26:25 -0600

Hi, I bought turtlebot full kit and am trying to move it.
However, I got some errors in this tutorial(Looking at Camera Data : http://www.ros.org/wiki/turtlebot/Tutorials/Looking%20at%20Camera%20Data).
I couldn't launch rviz with Asus EeePC. How do I solve it ?

I'm using Asus EeePC 1215B(This is a default PC for turtlebot).
It has Ubuntu 10.04 and ros electric.
I've already confirmed that turtlebot can be moved by teleoperation(turtlebot_teleop), so I think RobotSetup is correctly done.

I found one of the solution here(http://answers.ros.org/question/2109/rviz-in-ros-electric?answer=3627#3627), but I couldn't understand how to solve it in my case because of different configuration.

Here, I show the log data including four results.
1. terminal error1 : rosrun rviz rviz (on turtlebot laptop)
2. Ogre.log : got by the command "rosrun rviz rviz -l" (on turtlebot laptop)
3. terminal error2 : rosrun rviz rviz (on workstation)
4. troubleshooting : the result I got when I followed this page(http://answers.ros.org/question/2109/rviz-in-ros-electric?answer=3627#3627)

Thanks in advance.

///////////////////////////////////////
//terminal error (on turtlebot laptop)
///////////////////////////////////////
turtlebot@turtlebot-laptop:~$ rosrun rviz rviz
  [ INFO] [1341794677.953849619]: rviz revision number 1.6.7
  [ INFO] [1341794677.954535142]: ogre_tools revision number 1.6.3
  [ INFO] [1341794677.954618092]: compiled against OGRE version 1.7.3 (Cthugha)
  [ INFO] [1341794678.717732142]: Loading general config from [/home/turtlebot/.rviz/config]
  [ INFO] [1341794678.718407144]: Loading display config from [/home/turtlebot/.rviz/display_config]
  [ INFO] [1341794678.869544354]: RTT Preferred Mode is PBuffer.
  [ERROR] [1341794678.945262186]: Caught exception while loading: OGRE EXCEPTION(3:RenderingAPIException): Unable to create a suitable GLXContext in GLXContext::GLXContext at /tmp/buildd/ros-electric-visualization-common-1.6.3/debian/ros-electric-visualization-common/opt/ros/electric/stacks/visualization_common/ogre/build/ogre_src_v1-7-3/RenderSystems/GL/src/GLX/OgreGLXContext.cpp (line 61)

////////////////////////////////
//Ogre.log (on turtlebot laptop)
////////////////////////////////
09:50:26: Creating resource group General
09:50:26: Creating resource group Internal
09:50:26: Creating resource group Autodetect
09:50:26: SceneManagerFactory for type 'DefaultSceneManager' registered.
09:50:26: Registering ResourceManager for type Material
09:50:26: Registering ResourceManager for type Mesh
09:50:26: Registering ResourceManager for type Skeleton
09:50:26: MovableObjectFactory for type 'ParticleSystem' registered.
09:50:26: OverlayElementFactory for type Panel registered.
09:50:26: OverlayElementFactory for type BorderPanel registered.
09:50:26: OverlayElementFactory for type TextArea registered.
09:50:26: Registering ResourceManager for type Font
09:50:26: ArchiveFactory for archive type FileSystem registered.
09:50:26: ArchiveFactory for archive type Zip registered.
09:50:26: DDS codec registering
09:50:26: FreeImage version: 3.10.0
09:50:26: This program uses FreeImage, a free, open source image library supporting all common bitmap formats. See http://freeimage.sourceforge.net for details
09:50:26: Supported formats: bmp,ico,jpg,jif,jpeg,jpe,jng,koa,iff,lbm,mng,pbm,pbm,pcd,pcx,pgm,pgm,png,ppm,ppm,ras,tga,targa,tif,tiff,wap,wbmp,wbm,psd,cut,xbm,xpm,gif,hdr,g3,sgi,exr,j2k,j2c,jp2
09:50 ... (more)

edit retag flag offensive close merge delete

Comments

Could you please reformat your posting? For terminal output please prefix all lines with ' ' (four spaces) to preserve its formatting. A blockquote (prefix lines with a '>') is also acceptable. See markdown/syntax for more information.

ipso gravatar imageipso ( 2012-07-08 20:58:10 -0600 )edit

Thank you for your advice, ipso. I made it and added some info.If it doesn't look good, please say it.

moyashi gravatar imagemoyashi ( 2012-07-09 16:06:59 -0600 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2012-07-08 21:16:48 -0600

ipso gravatar image

updated 2012-07-09 21:01:42 -0600

rviz needs a working OpenGL setup, which means you need a proper installation of the drivers of your graphics card. The Radeon of the EeePC 1215B should be capable of running rviz, but it most likely needs the proprietary AMD drivers for it (the open-source drivers don't provide sufficient 3D acceleration as of this time AFAIK).

The output of glxinfo you posted indicates that you're currently making use of the default Mesa drivers, which is insufficient for rviz / OpenGL.

EDIT3: all wrong, OpenGL was working, OGRE needed OGRE_RTT_MODE=Copy again. See @weiin's answer (and the comments).


EDIT:

//terminal result (on workstation)
turtlebot@turtlebot-laptop:~$ rosrun rviz rviz Error: Unable to initialize 
gtk, is DISPLAY set properly?

Is this in a SSH session from your workstation to the EeePC? If so, this error is 'normal': your SSH session has no access to any running X instances.


EDIT2: Perhaps you should provide some more info on your setup. Which drivers have you installed, and which versions are they? What OS are you running? etc

edit flag offensive delete link more

Comments

I don't think the default Mesa drivers are insufficient. My glxinfo output is the same (OpenGL version string: 2.1 Mesa 7.7.1) and I run rviz quite fine. Running 'glxgears' should show whether OpenGL can work on the current drivers

weiin gravatar imageweiin ( 2012-07-08 22:12:02 -0600 )edit

Ok, that's why I added that my comment was 'as far as I know'. Perhaps you could post some more information on your setup (if it is relevant)?

ipso gravatar imageipso ( 2012-07-08 22:20:47 -0600 )edit

Thank you for your comments, ipso and weiin.

>Is this in a SSH session ... ? Yes, exactly. Thank you, I got it.

>Which drivers ... ? I added some infor the bottom of the above sentences.

I ran 'glxgears' and it worked well.

moyashi gravatar imagemoyashi ( 2012-07-09 16:18:11 -0600 )edit
0

answered 2012-07-09 16:30:25 -0600

weiin gravatar image

Based on a google search of your OGRE_EXCEPTION, you will find my previous question having the same exception here. Your glxinfo shows the same as mine when I had the problem (the "shading version" is missing).

When you ssh into turtlebot laptop from your workstation, you will not be able to run rviz (or any other X terminal for that matter) as ipso pointed out. If you insist on having rviz through ssh, you can use ssh -X turtlebot@turtlebotsIP, but note that the update will be slow(er).

edit flag offensive delete link more

Comments

Thank you, weiin. I tried followings. (1). "glxinfo | grep direct" and saw LIBGL_ALWAYS_INDIRECT is NO(echo $LIBGL_ALWAYS_INDIRECT result in 1) (2). export the variable = 0 and echo again, however saw it was 1.

moyashi gravatar imagemoyashi ( 2012-07-09 18:54:26 -0600 )edit

(3)Alt + F2 -> gnome-terminal and did (1), (2). But I got the same results. (4)Alt + F2 -> xterm and did (1), then I saw LIBGL_ALWAYS_INDIRECT is YES. (5)"rosrun rviz rviz" in xterm then I got the error "Texture for pass 0: creating with size 1x1 segmentation fault". Should I update all packages?

moyashi gravatar imagemoyashi ( 2012-07-09 19:02:37 -0600 )edit

I found the temporary solution here. (http://answers.ros.org/question/12140/how-to-run-rviz-with-ogre_rtt_mode-set-to-copy-or/) "(1)export OGRE_RTT_MODE=Copy, (2)rosrun rviz rviz", then it works well. But I can't understand the meaning. Is it good to avoid the errors?

moyashi gravatar imagemoyashi ( 2012-07-09 19:31:20 -0600 )edit

I think this http://unix.stackexchange.com/questions/1437/what-does-libgl-always-indirect-1-actually-do explains the direct rendering part quite well. Seems like RViz can only work with direct rendering. Segfault problems/solutions can be found here: http://ros.org/wiki/rviz/Troubleshooting

weiin gravatar imageweiin ( 2012-07-10 15:03:20 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-08 16:01:50 -0600

Seen: 853 times

Last updated: Jul 09 '12