can't find executable name when running the smach_viewer package

asked 2021-05-21 15:34:50 -0600

K3da gravatar image

i was following a tutorial from the book ROS Robotics Projects by Ramkumar Gandhinathan, Lentin Joseph in the 5th chapter when i run rosrun smach_viewer simple_fsm.py i get an error it says [rosrun] Couldn't find executable named simple_fsm.py below /opt/ros/melodic/share/smach_viewer even though i have sourced my workspace and it is in my $ROS_PACKAGE_PATH please can anyone tell me how to solve this problem? Thank you

edit retag flag offensive close merge delete

Comments

Try rosrun smach_viewer smach_viewer.py instead.

Orhan gravatar image Orhan  ( 2021-05-21 15:45:01 -0600 )edit

After running the command rosrun smach_viewer smach_viewer.py the terminal says wxversion 2.8 is not installed, installed versions are ['3.0-gtk3'](smach_viewer.py:3051): Gtk-WARNING **: 04:47:09.099: gtk_disable_setlocale() must be called before gtk_init()(smach_viewer.py:3051): Gtk-WARNING **: 04:47:11.661: Negative content height -11 (allocation 1, extents 6x6) while allocating gadget (node entry, owner GtkEntry) and some other warnings. When the smach_viewer opens all it says is PATH NOT AVAILABLE

K3da gravatar image K3da  ( 2021-05-22 04:01:03 -0600 )edit

i tried the suggestions in the link you gave but none of them worked for me i couldn't install wxPython 2.8

K3da gravatar image K3da  ( 2021-05-24 11:11:51 -0600 )edit