Ask Your Question
0

rosmake markers rviz

asked 2011-07-24 21:08:46 -0500

Wouter gravatar image

Hi,

I am trying to visualize an object that is based on points_and_lines.cpp in the rviz points and lines tutorials. However, when I change something to the cpp source and subsequently rosmake and rosrun the code, the old object keeps displayed. I have the feeling that rosrun runs an old executable or that rosmake does not properly renews the executable.

Do you have any idea how I can remove the 'old' executable that rosrun calls such that I am sure rosmake creates a new executable.

edit retag flag offensive close merge delete

Comments

have you tried calling "rosmake --pre-clean" (cleaning the executable before the build)
Bram van de Klundert gravatar image Bram van de Klundert  ( 2011-07-24 22:41:52 -0500 )edit
I have tried to do that but something seems to be wrong with 'rosmake'. It doesn't compile, it hangs and only gives this output: wouter@localhost:~/using_markers$ rosmake --pre-clean using_markers stem [ rosmake ] Packages requested are: ['using_markers', 'stem'] [ rosmake ] Logging to directory/home/wouter/.ros/rosmake/rosmake_output-20110725-133557
Wouter gravatar image Wouter  ( 2011-07-24 23:37:39 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-07-25 02:56:23 -0500

Wouter gravatar image

Apparently there was something wrong with my ROS_PACKAGE_PATH. the exported directory was my home/wouter/ directory and causes ros to search infinitely long for the package. Once changed to home/wouter/ros the issue was resolved.

Thanks Lorenz Mosenlechner

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-07-24 21:08:46 -0500

Seen: 225 times

Last updated: Jul 25 '11