ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Did rospy remapping arguments change in Fuerte?

asked 2012-02-19 14:22:13 -0600

Eric Perko gravatar image

updated 2012-02-20 13:36:03 -0600

I'm having a weird error with remapping arguments on Fuerte. In my rospy node, I have a line like

baud_rate = rospy.param('~baud',4800)

so when I'd like to change that on the commandline, I tried

rosrun nmea_gps_driver _baud:=38400

but instead of the parameter being set, I get the following error:

ERROR: Invalid remapping argument '_baud:=38400'

That remapping works just fine in Electric and I don't see anything in the rosrun or Fuerte Migration Guide.

In case it matters, I'm working against the latest Fuerte .debs on Ubuntu 11.10.


Minimal reproducible example:

import roslib
import rospy


test_param = rospy.get_param('~test', 4800)

print "Param was: %d" % (test_param)

If I run this like python _test:=38400, I get the error output. See below.

$ python _test:=38400
ERROR: Invalid remapping argument '_test:=38400'
Param was: 4800
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2012-02-20 13:45:45 -0600

kwc gravatar image

updated 2012-02-20 13:49:40 -0600

This was a bug due to some code refacotrintg. Fixed in r16352. Will be included in next ros_comm update.

BTW: thanks for the simplified test case, made this quick to fix

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2012-02-19 14:22:13 -0600

Seen: 664 times

Last updated: Feb 20 '12