Ask Your Question
0

roslaunch Problems

asked 2012-07-03 01:51:31 -0500

Astronaut gravatar image

updated 2012-07-03 03:51:52 -0500

This is the lauch file

<launch>

<node name="rosplay" pkg="rosbag" type="play" args="~/Desktop/PowRos/Data/User1/pow_freek_1_2011-04-01-14-17-41.bag             --clock"/>

<node pkg="tf" type="static_transform_publisher" name="baselink_laser" args="0 0 0 0 0 0 /base_link /laser 10"/>
<node pkg="tf" type="static_transform_publisher" name="laser_imu" args="0 0 0 0 0 0 /laser /base_imu 10"/>
<node pkg="tf" type="static_transform_publisher" name="baselink_camera" args="0 0 0 0 0 0 /base_link /camera 10"/>

<!-- Start the map server node and specify the map file (*.pgm) and the map resolution in metres/pixel -->
<node name="map_server" pkg="map_server" type="map_server" args="$(find amcl_listener)/maps/pow_real_time.yaml"         output="screen"/>

<!--Start the Laser_scan_matcher package, to provide odometry from laser data (ICP)-->
<node pkg="laser_scan_matcher" type="laser_scan_matcher_node" 
    name="laser_scan_matcher_node" output="screen">
    <param name="use_alpha_beta" value="true"/>
    <param name="max_iterations" value="10"/>
</node>

<!-- Start the gmapping node -->
<!--node pkg="gmapping" type="slam_gmapping" name="slam_gmapping" output="screen"/-->

<node pkg="amcl" type="amcl" name="amcl" respawn="true" output="screen">
    <param name="base_frame_id" value="base_link"/>
    <param name="odom_frame_id" value="world"/>
    <param name="global_frame_id" value="map"/>
    <param name="update_min_d" value="0.09"/>   
    <param name="update_min_a" value="0.09"/> 
    <param name="initial_pose_x" value="-1"/>
    <param name="initial_pose_y" value="0"/>
    <param name="initial_pose_a" value="-0.1"/>
    <param name="min_particles" value="6000"/> 
    <param name="max_particles" value="8000"/>
    <param name="odom_model_type" value="diff"/>
    <param name="kld_err" value="0.1"/> 
    <param name="resample_interval" value="1"/>
    <param name="odom_alpha1" value="0.2"/>   
    <param name="odom_alpha2" value="0.2"/>
    <param name="odom_alpha3" value="0.5"/>
    <param name="odom_alpha4" value="0.5"/>
    <param name="laser_max_beams" value="30"/>
</node>

<!--Start the "analyzer_packages"-->
<!-- acml_listener broadcasts markers for the position of the wheelchair, to visualize in Rviz-->
<node pkg="amcl_listener" type="amcl_pose_listener" name="amcl_listener" output="screen"/>
<!-- Object node records minimal ranges from laser, speed_node will record travel speed of wheelchair -->
<node pkg="pow_analyzer" type="object_node" name="object_node" output="screen"/>
<node pkg="pow_analyzer" type="speed_node" name="speed_node" output="screen"/>

<!-- Start an rviz node with a custom configuration for the viewpoint, map_server, trajectory, laser scans, etc -->
<node pkg="rviz" type="rviz" output="screen" name="rviz" args="-d $(find pow_analyzer)/launch/pow_rviz.vcg/>

</launch>

Ok it was a syntax error. Thanks

edit retag flag offensive close merge delete

Comments

be more specific, can you paste the launch file

cagatay gravatar imagecagatay ( 2012-07-03 01:53:30 -0500 )edit

ok. already done. Any help?

Astronaut gravatar imageAstronaut ( 2012-07-03 02:09:29 -0500 )edit

lacks a '<' at beginning, is it only a copy/paste error ?

Erwan R. gravatar imageErwan R. ( 2012-07-03 02:21:31 -0500 )edit

its just copy paste error. First line is <launch> and the last is </launch>. Thats not the problem.

Astronaut gravatar imageAstronaut ( 2012-07-03 02:24:48 -0500 )edit
1

Please don't completely overwrite your original question, otherwise answers and questions do not fit together anymore. This is confusing for other users. Instead, open a new question.

Lorenz gravatar imageLorenz ( 2012-07-03 03:01:53 -0500 )edit

ok sorry. thanks

Astronaut gravatar imageAstronaut ( 2012-07-03 03:49:22 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-07-03 01:53:25 -0500

Lorenz gravatar image

updated 2012-07-03 02:34:08 -0500

Your launch file is broken, something is probably malformed. Check the syntax and maybe update your question with the contents of the launch file so that we can check it and provide more help.

Edit: Please make sure that you really copy-pasted the complete launch file. It looks pretty broken.

  1. The first line should be <launch>, not launch>
  2. The last line needs to be </launch> which is completely missing.

Edit 2: There is a " missing in the last node definition:

<node pkg="rviz" type="rviz" output="screen" name="rviz" args="-d $(find pow_analyzer)/launch/pow_rviz.vcg/>

should be

<node pkg="rviz" type="rviz" output="screen" name="rviz" args="-d $(find pow_analyzer)/launch/pow_rviz.vcg" />

It helps to use an editor with syntax highlighting such as eclipse, vim or emacs or an actual xml editor to catch this kind of errors.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-03 01:51:31 -0500

Seen: 2,178 times

Last updated: Jul 03 '12