Ask Your Question
5

Ubuntu 12.04.2 and openni_launch not detecting Kinect after update?

asked 2013-04-12 04:21:56 -0500

djtubig-malicex gravatar image

updated 2016-10-24 09:09:30 -0500

ngrennan gravatar image

A few days ago I tested my brand new Kinect for XBOX 360 with my laptop after installing ROS Fuerte (with all TurtleBot packages/stacks) and installing the OpenNI/NITE files for the tracker workaround. Previously it worked, but after doing an update at some point, openni_launch (or even turtlebot_bringup kinect.launch) no longer detects the Kinect.

[ INFO] [1365810419.625569068]: [/openni_launch] No devices connected.... waiting for devices to be connected
[ INFO] [1365810420.627682000]: [/openni_launch] No devices connected.... waiting for devices to be connected
[ INFO] [1365810421.629791791]: [/openni_launch] No devices connected.... waiting for devices to be connected
[ INFO] [1365810422.634639075]: [/openni_launch] No devices connected.... waiting for devices to be connected
[ INFO] [1365810423.639501828]: [/openni_launch] No devices connected.... waiting for devices to be connected

Yet, lsusb sees the three devices:

djtubig-malicex@djtubig-aspire:~$ lsusb
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 1bcf:2c18 Sunplus Innovation Technology Inc. 
Bus 001 Device 008: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 010: ID 045e:02ad Microsoft Corp. Xbox NUI Audio
Bus 001 Device 009: ID 045e:02b0 Microsoft Corp. Xbox NUI Motor
Bus 001 Device 011: ID 045e:02ae Microsoft Corp. Xbox NUI Camera

Given it works under Windows (and even detects in Ubuntu via VMWare albeit no image since that doesn't work), I'm puzzled as to why this suddenly does not wish to be detected by the launcher.

Any advice for someone on 12.04.2? Thanks. I'm running out of ideas (and patience with inconsistent documentation around)

edit retag flag offensive close merge delete

Comments

I have the same problem than you, and didn't find any solution for the moment. If you find something, please share it...

CarolineQ gravatar imageCarolineQ ( 2013-04-15 00:13:29 -0500 )edit

Try uninstalling NITE (by using the ./uninstall) and reinstalling it. It has to be the old version of NITE (1.5.2 if I remember correctly). Let us know....

Stephane.M gravatar imageStephane.M ( 2013-04-15 22:59:34 -0500 )edit

Already tried that, and I'm already using the old version. No dice. :(

djtubig-malicex gravatar imagedjtubig-malicex ( 2013-04-15 23:37:55 -0500 )edit

If I were you, I would go to 12.10 then. But do a fresh install, updating is really not working well in the case of ROS/kinect/general stuff... I know this solution is a bit long, but it's what I did... And I hope it'll work for you...

Stephane.M gravatar imageStephane.M ( 2013-04-15 23:42:38 -0500 )edit

Found the solution to the problem. This is what happens when you install drivers over existing ones that worked, with ones that don't work. :(

djtubig-malicex gravatar imagedjtubig-malicex ( 2013-04-16 01:57:06 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
11

answered 2013-04-16 01:50:35 -0500

djtubig-malicex gravatar image

updated 2013-04-16 18:49:15 -0500

After exploring Stephane.M's suggestion of reinstallation, it turns out the fault was an unintentional curiosity that killed everything.

The culprit: OpenNI-compliant SensorKinect Linux-x64 driver on the OpenNI website

The cure: Avin2 GitHub snapshot of SensorKinect drivers - look in Bin folder and use the package relevant to your OS to install the driver.

Despite having a very similar version number, it appears the current SensorKinect build on the github works fine, while the one on the OpenNI website broke any application attempting to use the Kinect. If problems persist running the install script, do a sudo ./install.sh -u first before installing.

I hope this is a solution to anyone out there that curiously tried to install the OpenNI driver only to find it breaks something. :)

edit flag offensive delete link more

Comments

1

not perfect, but the best openni version I ever used. The XnSensorServer needs a few seconds to terminate after stopping my program (I have to wait before I can restart), but it works.

MichaelKorn gravatar imageMichaelKorn ( 2013-04-16 04:32:52 -0500 )edit

Oh ! Good if you didn't had to reinstall :-) And now you gave this solution, it's true that I also had this problem, so reinstalling must have solved it.... I always install avin2 now :-) Have a good day !

Stephane.M gravatar imageStephane.M ( 2013-04-16 06:04:44 -0500 )edit
1

Yeah, I was actually toying on the idea of falling back to a LiveUSB installation if reinstallation were the case. If it weren't for the guide on this page for clues I probably would have done so: http://igorbarbosa.com/articles/how-to-install-kin-in-linux-mint-12-ubuntu/

djtubig-malicex gravatar imagedjtubig-malicex ( 2013-04-16 18:57:12 -0500 )edit

I followed the same step and it works for me as well ! Very nice ! Thanks !

CarolineQ gravatar imageCarolineQ ( 2013-04-16 21:58:45 -0500 )edit

I ran into this problem a couple weeks ago after updating to ROS hydro. I have followed these steps, but this does not seem to be the problem. Is it likely I screwed up the installation, or could this problem be caused by something else?

randylewis7 gravatar imagerandylewis7 ( 2014-04-14 09:54:24 -0500 )edit

Can you please tell me how to run the install script on Ubuntu 12.04? I have downloaded the zip file, but which commands should I use in Ubuntu to install the file.

ish45 gravatar imageish45 ( 2014-08-31 13:08:54 -0500 )edit
2

@ish45 assuming you have Ubuntu 12.04 64bit:

cd ~/Downloads
unzip avin2-SensorKinect-v0.93-5.1.2.1-0-g15f1975.zip 
cd avin2-SensorKinect-15f1975/Bin
tar -xjf SensorKinect093-Bin-Linux-x64-v5.1.2.1.tar.bz2
cd Sensor-Bin-Linux-x64-v5.1.2.1
sudo ./install.sh
isura gravatar imageisura ( 2014-10-13 23:29:05 -0500 )edit

Wow!!!!!! That worked for me, thanks a lot !!!!!

ingcavh gravatar imageingcavh ( 2014-10-14 00:08:31 -0500 )edit
1

answered 2013-11-26 05:16:04 -0500

TFinleyosu gravatar image

FYI, I had this same issue. I think I screwed up things when I was trying differnt drivers to get the Primesense Carmine working and then my Kinect stopped working. I ended up just reinstalling all libopenni via Synaptic and it started working again.

edit flag offensive delete link more

Comments

1

You biscuit - I have been looking everywhere and this solved it.. unreal..

kleinsplash gravatar imagekleinsplash ( 2014-01-13 01:06:53 -0500 )edit

I've never been called a biscuit before... not sure what it means even...

TFinleyosu gravatar imageTFinleyosu ( 2014-02-07 06:41:49 -0500 )edit
1

Weell in that case: http://www.southafrica.info/travel/advice/saenglish.htm#.Uvh9Gvjzsak - you will notice that Ubuntu is also described..

kleinsplash gravatar imagekleinsplash ( 2014-02-09 19:21:01 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2013-04-12 04:21:56 -0500

Seen: 14,991 times

Last updated: Nov 26 '13