Baxter Robot: enable robot failed.

asked 2021-04-06 09:17:41 -0500

Ziyang Xie gravatar image

Hi all,

I'm new to Baxter robot (previously I'm using Sawyer). I configured the environment in Ubuntu 16 using Ros kinetic. Everything was good except there is an error when I use cmake to install Baxter environment. I can ping the robot, read the rostopic, and get joint angles from the robot. But I cannot enable the robot and control it.

Specifically, when I run

rosrun baxter_tools enable_robot.py -e

It shows:

**[WARN] [WallTime: 1453764465.061960] RobotEnable: Failed to retrieve robot version from rosparam: rethink/software_version Verify robot state and connectivity (i.e. ROS_MASTER_URI)

I also tried:

rosparam get /rethink/software_version

It returns

ERROR: Parameter [/rethink/software_version] is not set.

I'm sure the robot is booted and the baxter.sh is correctly set (since I can read rostopic list).

Does anyone know what's the problem?

Thanks in advance!

edit retag flag offensive close merge delete