Rtabmap recieving inconsecutive timestamps for odometry

asked 2021-03-02 05:30:11 -0500

liambroek gravatar image

updated 2021-03-02 05:31:24 -0500

I'm using ROS melodic with a realsense d435 camera on a turlebot 3 burger with a raspberry pi 4. I'm using rtabmap to do the mapping. So my problem is that when I run rtabmap its often receives data with incorrect timestamps. The warning looks like this:

Odometry: Detected not valid consecutive stamps (previous=1614669993.243914s new=1614669987.932037s). New stamp should be always greater than previous stamp. This new data is ignored. This message will appear only once.

When I plug the camera into my pc, launch the camera node and run rtabmap on there it works fine. But with the camera plugged into the PI, launching the camera node from there, it shows the error. I initially though it was a network issue (data being sent too slowly between the systems). So I've also tried running roscore on the Pi, along with the camera node and rtabmap (nothing transmitted over the network), but the same issue occurs. I'm launching rtabmap with approx_sync:=true, and on the camera node enable_sync:=true and inital_reset:=true.

Any suggestions on how to improve this?

edit retag flag offensive close merge delete


which realsense sdk version are you using? and which firmware is installed on the camera?

matlabbe gravatar image matlabbe  ( 2021-03-02 13:34:53 -0500 )edit

I'm using the realsense-ros package, I think that's the realsense 2.0 sdk. The firmware version is:

liambroek gravatar image liambroek  ( 2021-03-03 02:45:48 -0500 )edit

I am on realsense v.2.42.0, with firmware on a D435i.

matlabbe gravatar image matlabbe  ( 2021-03-04 07:02:45 -0500 )edit

I checked the delay of the data sent along the /camera/aligned_depth_to_color/image_raw topic. When the device is plugged into my pc, the delay is usually around 0.2 seconds. When plugged into the pi the delay is 34222 seconds. Any ideas on what to do with this issue?

liambroek gravatar image liambroek  ( 2021-03-11 03:35:40 -0500 )edit