ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

"Unable to locate package ros-diamondback/electric-nxtall"

asked 2012-06-22 07:53:56 -0600

Nezteb gravatar image

updated 2014-01-28 17:12:47 -0600

ngrennan gravatar image

My name is Noah and I am a novice programmer looking to use ROS with the NXT Lego robotics kits. I succeeded in installing the generic ROS and am partway through the beginner tutorials even. However, I recently tried to install the ROS NXT release and received the error message in the title. The first thing I realized was that there doesn't seem to be an NXT package for Fuerte, although I don't know if that is an issue for sure. However, I have tried the main ROS server as well as each of the mirrors and cannot locate any of the NXT packages even though looking through the mirrors manually I can even see the packages that I am looking for. Any help would be greatly appreciated. :)

EDIT: Also using a Virtual Machine (VirtualBox) running Ubuntu Precise 12.04 LTS and ROS Fuerte. The command I tried running was:

sudo apt-get install ros-electric-nxtall (also tried for diamondback)

Which returned the following:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ros-electric-nxtall

I think what I'm going to try to do is just removing this VM and reinstalling with something like Ubuntu 10.04 and getting ROS Electric, which as far as I can tell will definitely work. I just wanted to avoid doing so as my internet connection is relatively slow and I'd like to avoid wasting the several hours I spent setting ROS up. Oh well though; I guess that's the life of a programmer.

edit retag flag offensive close merge delete


Please post the exact command you ran, along with the exact error message you got.

Dan Lazewatsky gravatar image Dan Lazewatsky  ( 2012-06-22 08:03:04 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2012-06-22 08:31:28 -0600

Debs pre-Fuerte are not available on 12.04. Installing 10.04 like you mentioned will certainly do the trick.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2012-06-22 07:53:56 -0600

Seen: 687 times

Last updated: Jun 22 '12