ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Connecting to Husky's Hokuyos

asked 2021-01-21 15:31:26 -0500

EricW gravatar image


I'm working with a Husky that has two Hokuyo laser scanners. I just started working in the lab and until now, no one has used the lidars. I tried following online tutorials and answers, but they all assume that the lidars will appear with: $ ls -l /dev/ttyACM0

However, no device is found when I do that. The two lidars both have a blue light on and are plugged into the Husky, so I believe they are working. Additionally, I installed the urg_node. There is no lidar data being published on any topics and no lidar data is displayed when viewing the Husky in RViz.

I would really appreciate some advice on how to connect to the lidars.

Thanks so much!

edit retag flag offensive close merge delete


When you plug in the lidars, what devices do they show up as? You will have to search for them in /dev and replace the /dev/ttyACM0 with the appropriate device id's. You could use dmesg -wH and then plug in your lidars and see what devices they show up as. I would also urge you to set the correct udev rules as mentioned in their wiki.

Akhil Kurup gravatar image Akhil Kurup  ( 2021-01-21 15:56:06 -0500 )edit

@Akhil Kurup thanks so much for the response! I tried using dmesg and unplugged and plugged in both lidars, but nothing shows up. Any ideas?

EricW gravatar image EricW  ( 2021-01-21 16:17:27 -0500 )edit

After you figure this out, make sure you reflect these changes in the urg_lidar.launch file.

Akhil Kurup gravatar image Akhil Kurup  ( 2021-01-21 16:19:35 -0500 )edit

@EricW sorry, I haven't used these lidars myself.

Akhil Kurup gravatar image Akhil Kurup  ( 2021-01-21 16:20:14 -0500 )edit

Here's a script that may help:

for sysdevpath in $(find /sys/bus/usb/devices/usb*/ -name dev); do
        devname="$(udevadm info -q name -p $syspath)"
        [[ "$devname" == "bus/"* ]] && exit
        eval "$(udevadm info -q property --export -p $syspath)"
        [[ -z "$ID_SERIAL" ]] && exit
        echo "/dev/$devname - $ID_SERIAL"

You can just copy it in a terminal. Example output:

/dev/input/event3 - Logitech_USB_Optical_Mouse
/dev/input/mouse0 - Logitech_USB_Optical_Mouse
/dev/input/event4 - SEMICO_USB_Keyboard
/dev/input/event6 - SEMICO_USB_Keyboard
/dev/input/event5 - SEMICO_USB_Keyboard
/dev/input/event7 - SEMICO_USB_Keyboard
/dev/sdc - SanDisk_Ultra
/dev/sdc1 - SanDisk_Ultra
tryan gravatar image tryan  ( 2021-01-25 09:00:51 -0500 )edit

Thanks so much for the response @tryan! I ran it and my output is:

/dev/ttyUSB0 - Prolific_Technology_Inc._USB-Serial_Controller
/dev/input/event3 - Metadot_-_Das_Keyboard_Das_Keyboard
/dev/input/event4 - Metadot_-_Das_Keyboard_Das_Keyboard
/dev/input/mouse0 - PixArt_USB_Optical_Mouse
/dev/input/event2 - PixArt_USB_Optical_Mouse
/dev/input/js0 - Logitech_Wireless_Gamepad_F710_A71A9A88
/dev/input/event14 - Logitech_Wireless_Gamepad_F710_A71A9A88
/dev/ttyUSB1 - FTDI_Clearpath_Robotics__um7_FTA4G81I

Which looks to me like the lidars aren't connected

EricW gravatar image EricW  ( 2021-01-25 12:08:39 -0500 )edit

I was assuming you're working with a USB device. Are the sensors you're using ethernet? If so, you'll have to set the ip_address parameter for urg_node.

tryan gravatar image tryan  ( 2021-01-25 12:46:51 -0500 )edit

@tryan would you mind clarifying how to find the ip address? I found one document that said the addresses were:

| Front Hokuyo UST10LX IP     |  |
| Rear Hokuyo UST10LX IP      |  |

But if I ping those addresses I don't get any response.

EricW gravatar image EricW  ( 2021-01-25 13:28:19 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2021-02-04 16:23:26 -0500

EricW gravatar image

This ended up being an issue with using a normal Ubuntu ISO to upgrade the Husky instead of the Clearpath provided ISO. I was able to fix this by contacting Clearpath support.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2021-01-21 15:31:26 -0500

Seen: 161 times

Last updated: Feb 04 '21