Clearpath Husky connection problems in Fuerte [closed]

asked 2013-06-27 02:38:22 -0600

kamek gravatar image

updated 2014-01-28 17:17:04 -0600

ngrennan gravatar image

Has anyone recently been able to teleoperate the Husky in Fuerte using the directions described here?

When I run sudo apt-get install ros-fuerte-clearpath-husky-robot I get E: Unable to locate package ros-fuerte-clearpath-husky-robot even after updating my repositories. So I went with the other suggestion (which was preferred, anyway): using an overlay. After "successfully" installing the overlay with

rosinstall OVERLAY_NAME

I connected my laptop to the Husky with a serial->USB connector. I tried to launch the Husky with

roslaunch husky_bringup base.launch port:=/dev/ttyUSB0

And I get an error about the ClearpathRobot.msg not existing. So I figure I need to rosmake the clearpath_common package. Doing so prints out an error about the Joy package not being installed. So I installed the Joy package and tried again. This time it was successful. Now when I try to launch the Husky I get an error saying that the connection on ttyUSB0 cannot be found. I have noted that with dmesg, the converter is indeed attached to ttyUSB0.

And now I'm stuck. Any suggestions? I am running Ubuntu 11.10.

As a side note, I was able to successfully connect to the Husky using Groovy using these directions. However, that wasn't without a weird problem: it would only find the connection on ttyUSB0 when I had another cable plugged into ttyUSB1 as well (ttyUSB0 connected to Husky, ttyUSB1 connected to nothing).

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2015-10-26 13:34:02.797194