ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Failed to release into Fuerte

asked 2012-03-04 21:35:49 -0500

Thomas gravatar image

Hello, I am trying to release the vision_visp stack into Fuerte but I have the following error message:

ERROR: No rosdep rule can be found for key [u'boost']

This release script uses rosdep 2, which does not read files from
<stack-name>/rosdep.yaml.  Please see the following documentation on
how to add the rules you need for release:

I assume that Boost is part of the core rosdep dependencies that are already in rosdep 2 so I don't understand what I should do.

By the rosdep 2 documentation indicates that dependency lookup is done through /etc/ros/rosdep/sources.list.d. This directory does not exist on my computer, neither does /opt/ros/fuerte/etc/ros/rosdep/sources.list.d. Is it normal?

I do not use shadow repos. Does it explain why it does not work?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2012-03-04 22:03:59 -0500

AHornung gravatar image

Check out

rosdep requires an initialization by running

sudo rosdep init
rosdep update

This will first update (or create) the system rules in /opt/ros/fuerte/etc/ros/rosdep/sources.list.d and then update your local user's cache (in ~/.ros). You could also update rosdep itself, I believe the newest version gives a warning when running with an empty sources.list.d. I had to learn this the hard way too ;)

edit flag offensive delete link more


Thanks, I misses this. Now it is way better :) It probably would be intersting that rosdep 2 suggests to run the following command when no DB exists...

Thomas gravatar image Thomas  ( 2012-03-05 00:43:08 -0500 )edit

Question Tools


Asked: 2012-03-04 21:35:49 -0500

Seen: 318 times

Last updated: Mar 04 '12