Ask Your Question
0

pre-release test error on hudson

asked 2011-03-22 15:37:05 -0500

ben gravatar image

updated 2011-03-22 15:41:17 -0500

I'm using the fancy code release system for the first time and it seems to be very impressive how everything gets auto-magically generated for you however I ran into a problem last week when I tried a pre-release test.

I should mention that I'm the repository maintainer and so I first followed the Repository Setup Instructions - so just bear in mind that the problem may not be with the stack itself but maybe it's a problem with the entire repo configuration in the rosdistro.

I tried to run a Hudson Pre-Release test and I got the following error in Diamiondback and Unstable on all of the platforms. It doesn't seem like it even got up compiling code so I don't know where to start debugging the problem...

Command failed: Command '['sudo', 'chroot', '/home/rosbuild/chroot/prerelease_unstable_sbpl_arm_planning_lucid_amd64', 'su', 'rosbuild', '-s', '/bin/bash', '-c', "HUDSON_URL='http://build.willowgarage.com/' BUILD_URL='http://build.willowgarage.com/job/prerelease_unstable_sbpl_arm_planning_lucid_amd64/1/' BUILD_TAG='hudson-prerelease_unstable_sbpl_arm_planning_lucid_amd64-1' JOB_NAME='prerelease_unstable_sbpl_arm_planning_lucid_amd64' BUILD_ID='2011-03-17_14-10-59' BUILD_NUMBER='1' JOB_URL='http://build.willowgarage.com/job/prerelease_unstable_sbpl_arm_planning_lucid_amd64/' EXECUTOR_NUMBER='0' /tmp/script.sh"]' returned non-zero exit status 255 ectory_filters', 'pr2_kinematics'] Adding dependencies of stack sensor_msgs Command failed, shutting down chroot Shutting down

You can also check out the entire hudson console output.

Does anyone know how I can resolve this problem?

Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-03-22 19:18:31 -0500

kwc gravatar image

I think it is failing because "sensor_msgs" is not a stack. "common_msgs" is.

You can recalculate your stack dependencies by running:

roscd yourstack
roscreate-stack .

Note: we don't auto-calculate stack dependencies because this prevents dependencies from accidentally sneaking in.

edit flag offensive delete link more

Comments

That was the problem. I had sensor_msgs and common_msgs listed in the stack.xml. I won't be as careless in the future. Thanks.
ben gravatar imageben ( 2011-03-23 02:43:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-03-22 15:37:05 -0500

Seen: 149 times

Last updated: Mar 22 '11