Ask Your Question
0

AMCL husky problems [closed]

asked 2013-04-06 09:51:56 -0500

updated 2014-01-28 17:16:04 -0500

ngrennan gravatar image

Hi,

I am trying to use amcl to drive a robot around my school. It failed to load saved maps, but seemed to accept when I told it to use the /map topic. The problem I am having now though is that nothing is happening. I have tried using the amcl_demo.launch file, as well as launching amcl_husky.launch and move_base_husky.launch separately. In rviz I press the 2D pose estimate button to set the pose, but there is no effect. In the terminal it states that it is setting the post on frame /map and gives coordinates, but rviz does not show the collection of arrows that the wiki says it should. As well, when I press the 2D Nav Goal button and select the goal, the terminal states that it is setting the goal in frame /map and gives the position and orientation coordinates but again nothing shows up in rviz and the robot does not move. I am not sure what is going on and would appreciate any help you can give. I am following the turtlebot_navigation tutorial as it says to do on the husky navigation page on the wiki, except that I am using the /map topic rather than a saved map as I stated above.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Icehawk101
close date 2013-04-20 02:56:16

Comments

@Icehawk101 you can just accept the answer and it will get filtered as closed, you don't need to close it as well.

tfoote gravatar imagetfoote ( 2013-04-18 10:40:06 -0500 )edit

Oh, I didn't know that. Thanks for the info.

Icehawk101 gravatar imageIcehawk101 ( 2013-04-18 10:43:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-04-18 10:23:47 -0500

So I got it working. Turns out that in the move_base_husky.launch file the velocity commands are mapped from cmd_vel to plan_cmd_vel. I changed that to /husky/cmd_vel and the robot started moving.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-04-06 09:51:56 -0500

Seen: 283 times

Last updated: Apr 18 '13