Ask Your Question
0

move_base does not load plugin

asked 2020-12-06 22:30:35 -0500

hiep127 gravatar image

updated 2020-12-07 02:12:00 -0500

Hello,

I'm just begin to use ROS for about 3 months to do a project in my university. I am having a problem with move_base server since it seem not able to come up. When i run rostopic list there a few topic appear (https://imgur.com/LlIR150). I also try send a simple goal with the code finding in https://bit.ly/36MHiFC (ROS tutorial sending a navigation goal) but nothing happen (https://imgur.com/WHLMcah). Since there are no error show up i dont know what i have done wrong

Can anyone help me with this

I'm very appreciated your help

This is my terminal when i run the move_base server (https://imgur.com/Szk0QmB)

And this is my move_base launch file (https://imgur.com/qovh44U)

edit retag flag offensive close merge delete

Comments

@hiep127 for any text please don't use images as the text in images can't be copy and pasted. Please see the support page

jayess gravatar image jayess  ( 2020-12-15 21:02:45 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2020-12-07 08:23:55 -0500

miura gravatar image

At least, odom, map, and sensor_topic are missing. Also read the move_base documentation.

http://wiki.ros.org/move_base#move_ba...

edit flag offensive delete link more

Comments

Thank you for your reply

yeah it seem like the tf from map to base link is missing cause i have tried runiing all those topic already and still nothing happend

hiep127 gravatar image hiep127  ( 2020-12-07 08:36:50 -0500 )edit
1

You may try doing the following set: https://github.com/yuthikasagarage/2D...

miura gravatar image miura  ( 2020-12-07 08:44:14 -0500 )edit

Okay thanks <3

hiep127 gravatar image hiep127  ( 2020-12-07 08:47:15 -0500 )edit
0

answered 2020-12-07 01:59:25 -0500

hiep127 gravatar image

After search the web it seem like my move_base does not load plugin but i still dont know why ...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-12-06 22:28:25 -0500

Seen: 124 times

Last updated: Dec 07 '20