Ask Your Question

About the "[gazebo_gui-3] process has died"

asked 2020-11-13 05:16:56 -0500

1210652636 gravatar image

When I run the code "roslaunch turtlebot3_gazebo turtlebot3_empty_world.launch" in the terminal, some errors happened: “ [gazebo_gui-3] process has died [pid 3119, exit code 134, cmd /opt/ros/noetic/lib/gazebo_ros/gzclient __name:=gazebo_gui __log:=/home/xzs/.ros/log/fb554976-25a0-11eb-a6f7-4fc1cbbb85d3/gazebo_gui-3.log]. log file: /home/xzs/.ros/log/fb554976-25a0-11eb-a6f7-4fc1cbbb85d3/gazebo_gui-3*.log

” I am a new user of ROS, maybe this problem is a little stupid, but I will improve myself. Could you tell me how to figure it out?

edit retag flag offensive close merge delete


@1210652636 Gazebo is a simulation program that comes with two entities: gzserver that is the core of the simulation and gzclient that is the GUI. What is failing in your machine is the GUI. So it may be something realted with your graphical set up. Have you tried to run Gazebo without GUI and see what happens? Also, ensure the world you are using exists and the environmental variables for the turtlebot are properly set up.

Weasfas gravatar image Weasfas  ( 2020-11-13 05:31:43 -0500 )edit

Could you tell me how to set up the gzclient? I don't recall that word ever appearing during my installation.

1210652636 gravatar image 1210652636  ( 2020-11-13 05:40:58 -0500 )edit

@1210652636 you do not really need to set up the gzclient since it should work with any problems. For the moment you only want to know what is the problem. For this reason, to debug this, first, you can launch Gazebo alone and see if it is something related with your machine or with the launch files. Open a terminal and launch Gazebo (E.g.: gazebo empty.wold). Then if the same error appears try to launch Gazebo without the client, setting the parameter of the launch file to false. (E.g.: <arg name="gui" value="false"/>). If the error is still going then it must be something related with your graphics.

Weasfas gravatar image Weasfas  ( 2020-11-13 05:55:19 -0500 )edit

Thank you so much I will try it.

1210652636 gravatar image 1210652636  ( 2020-11-13 05:57:34 -0500 )edit

By the way, when I open a new terminal and run the code "export SVGA_VGPU10=0", this error is gone. But next time, when I run "roslaunch turtlebot3_gazebo turtlebot3_empty_world.launch", the same error happened. So I have to run "export SVGA_VGPU10=0" again and again befor run "roslaunch ... ".

1210652636 gravatar image 1210652636  ( 2020-11-13 06:00:24 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2020-11-13 06:43:58 -0500

Weasfas gravatar image

@1210652636 Oh! Ok, that is the problem.

You are running in a virtual environment. For future post if you work in virtual environment try to add this information with your question.

Gazebo does not work very well with Virtual Machines, you will have to disable from the VM setting the option of 3D acceleration. Gazebo has some issues with that option enable. Once you disabled that option you will have a simulation environment a bit slow but fully working.

When you change the SVGA_VGPU10 variable you are just telling what OpenGL version, you can try both options and see which one is better for you. If you want to use this option to avoid setting this variable every time you start a terminal just add this command to the .bashrc. (E.g.: echo "export SVGA_VGPU10=0" >> ~/.bashrc).

Hope this helps.


edit flag offensive delete link more


Thanks a lot!!!

1210652636 gravatar image 1210652636  ( 2020-11-15 05:23:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2020-11-13 05:16:56 -0500

Seen: 5,330 times

Last updated: Nov 13 '20