Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

@1210652636 Oh! Ok, that is the problem.

You are running in a virtual environment. For future post if you work in virtual environment try to add this information with your question.

Gazebo does not work very well with Virtual Machines, you will have to disable from the VM setting the option of 3D acceleration. Gazebo has some issues with that option enable. Once you disabled that option you will have a simulation environment a bit slow but fully working.

When you change the SVGA_VGPU10 variable you are just telling what OpenGL version, you can try both options and see which one is better for you. If you want to use this option to avoid setting this variable every time you start a terminal just add this command to the .bashrc. (E.g.: echo "export SVGA_VGPU10=0" >> ~/.bashrc).

Hope this helps.

Regards.