Unable to locate package ros-kinetic-[...]

asked 2017-07-23 11:38:58 -0500

Cooper1993 gravatar image

updated 2017-07-23 12:07:48 -0500

gvdhoorn gravatar image


I'm using Ubuntu 16.04 LTS with ROS Kinetic. I'm trying to install the packages necesaries to use the turtleBot3 simulator. I'm following this tutorial: link text. In this link they say that: "This instruction was tested on Ubuntu 16.04 and ROS Kinetic Kame"

And I can't install some packages like joy, navigation, teleop-twist-joy, etc. Because it gives me an error like:

E: Unable to locate package ros-kinetic-joy

Someone knows why?

I tried: sudo apt-get update and then

sudo apt-get install ros-kinetic-joy ros-kinetic-teleop-twist-joy ros-kinetic-teleop-twist-keyboard ros-kinetic-laser-proc ros-kinetic-rgbd-launch ros-kinetic-depthimage-to-laserscan ros-kinetic-rosserial-arduino ros-kinetic-rosserial-python ros-kinetic-rosserial-server ros-kinetic-rosserial-client ros-kinetic-rosserial-msgs ros-kinetic-amcl ros-kinetic-map-server ros-kinetic-move-base ros-kinetic-urdf ros-kinetic-xacro ros-kinetic-compressed-image-transport ros-kinetic-rqt-image-view ros-kinetic-gmapping ros-kinetic-navigation
edit retag flag offensive close merge delete


Do you have you apt sources set up for ROS? Have you installed any other ROS packages?

ahendrix gravatar image ahendrix  ( 2017-07-23 11:51:42 -0500 )edit

I think that yes... For example, I can install ros-kinetic-ros-tutorials and the other packages that I find in apt-cache search ros-kinetic, but I can't find (using search) those packages that I want to install...

Cooper1993 gravatar image Cooper1993  ( 2017-07-23 18:25:32 -0500 )edit

any updates on this? i kinda have the same problem

HenryZh47 gravatar image HenryZh47  ( 2017-10-14 13:58:37 -0500 )edit

Same problem here. All details to my question are here. Also followed the suggestions from this question to update the ROS repo but it didn't work. Any ideas?

flyingROS gravatar image flyingROS  ( 2017-10-26 14:14:37 -0500 )edit

@flyingROS: you forgot to mention that you're on ARMv7. Are the packages you want to install actually released and being built for that platform?

gvdhoorn gravatar image gvdhoorn  ( 2017-10-26 14:22:28 -0500 )edit

I'm trying to install mavros and in the readme it says that there are binary packages for armhf (ARMv7). Tried to install from source. How can I find out if source installation is possible for my platform?

flyingROS gravatar image flyingROS  ( 2017-10-26 14:30:43 -0500 )edit

According to status_page/ros_kinetic_uxhf.html?q=mavros and status_page/ros_kinetic_uxv8.html?q=mavros there are indeed binaries, so if apt can't ..

gvdhoorn gravatar image gvdhoorn  ( 2017-10-26 14:35:51 -0500 )edit

.. find them, I would suspect a system configuration issue.

Are you running Xenial or Jessie? And for the right cpu arch?

gvdhoorn gravatar image gvdhoorn  ( 2017-10-26 14:37:04 -0500 )edit