ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Cannot download ros-kinetic-ros-tutorials

asked 2016-12-26 07:57:24 -0500

sharan100 gravatar image

updated 2016-12-26 14:02:47 -0500

Making my way through this guide right here. Currently running Kinetic on the Raspbian Jessie Lite, which itself is running on the Raspberry Pi 3. So I'm trying to complete the pre-requisite which is the command:

sudo apt-get install ros-kinetic-ros-tutorials

However, whenever I try to install this, I get the error:

E: Unable to locate package ros-kinetic-ros-tutorials

sudo can't locate ros-indigo or ros-jade either. In terms of the etc/apt/source.list.d/ros-latest.list, I have:

deb jessie main

I have done a sudo update and a sudo upgrade, but neither seems to work. I have noticed a lot of questions around with this problem, but can't seem to find a solution to my specific problem.


After a suggestion from the two answers below, I have realised that I cannot use sudo-apt-get install on packages when I have built ROS-Kinetic from source. Now, I have tried running the four commands:

rosinstall_generator ros_comm ros-kinetic-ros-tutorials --rosdistro kinetic --deps --wet-only --tar >kinetic-custom_ros.rosinstall 

rosinstall_generator ros-kinetic-ros-tutorials --rosdistro kinetic --deps --wet-only --tar >kinetic-custom_ros.rosinstall 

rosinstall_generator ros_comm ros_kinetic_ros_tutorials --rosdistro kinetic --deps --wet-only --tar >kinetic-custom_ros.rosinstall 

rosinstall_generator ros_kinetic_ros_tutorials --rosdistro kinetic --deps --wet-only --tar >kinetic-custom_ros.rosinstall

But I still get the error: The following not released packages stacks will be ignored: ros-kinetic-ros-tutorials. What exactly am I doing wrong in trying to build this from source?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2016-12-26 13:41:23 -0500

patrchri gravatar image

updated 2016-12-26 16:30:04 -0500

There are instructions here to install extra packages in ROS Kinetic in the raspberry pi 3. Read the page carefully.


What you need to run is the following:

cd ~/ros_catkin_ws
rosinstall_generator ros_comm your_extra_packages --rosdistro kinetic --deps --wet-only --tar > kinetic-custom_ros.rosinstall
wstool merge -t src kinetic-custom_ros.rosinstall
wstool update -t src
rosdep install --from-paths src --ignore-src --rosdistro kinetic -y -r --os=debian:jessie
sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/kinetic

which from what I see, you probably tried it.

Ensure that the ROS repository is up to date, by following once again:

sudo sh -c 'echo "deb $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list'
sudo apt-key adv --keyserver hkp:// --recv-key 421C365BD9FF1F717815A3895523BAEEB01FA116
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install -y python-rosdep python-rosinstall-generator python-wstool python-rosinstall build-essential cmake
sudo rosdep init
rosdep update

and then try the installation again. Also try to install another package for example ros_control and see if this works and the problem is only related to ros-kinetic-ros-tutorials.

edit flag offensive delete link more



As mentioned in the comment by ahendrix in his answer below:

"The ros-kinetic part of the apt package name is not part of the ROS package name. The ROS package is named ros_tutorials."

sharan100 gravatar image sharan100  ( 2016-12-27 09:34:53 -0500 )edit

I've been battling with the same issue, and I'm personally attempting to install this package on a Raspberry Pi 4 with Raspbian (debian: buster). In the installation guide shown here, it's stated that rospack uses libboost1.58, rather than the automatically installed libboost1.67. Upon initial setup, the instructions prove to be correct and allow successful installation. at the moment you invoke

rosdep install --from-paths src --ignore-src --rosdistro kinetic -y -r --os=debian:jessie'

after merging with wstool, libboost1.67 is installed again and creates more errors when building the catkin workspace. I believe that the package "ros_tutorials" is dependent on libboost1.67, which creates serious conflict.

jlzaphoid gravatar image jlzaphoid  ( 2020-05-12 09:18:19 -0500 )edit

answered 2016-12-26 12:45:14 -0500

ahendrix gravatar image

Which install guide did you follow when installing ROS?

If you installed from APT, it's possible that those packages aren't released for ARM.

If you installed from source, you'll need to install the tutorials from source too.

edit flag offensive delete link more


Any links to where I can get these tutorials from source? I installed from source.

sharan100 gravatar image sharan100  ( 2016-12-26 13:29:21 -0500 )edit

This was where I installed from. As patrichri suggests, I tried using the same guide to build it from source, but that seems to have failed. please look at the Update section in my question above.

sharan100 gravatar image sharan100  ( 2016-12-26 13:45:02 -0500 )edit

The ros-kinetic part of the apt package name is not part of the ROS package name. The ROS package is named ros_tutorials.

ahendrix gravatar image ahendrix  ( 2016-12-27 01:01:29 -0500 )edit

Question Tools



Asked: 2016-12-26 07:57:24 -0500

Seen: 6,914 times

Last updated: Dec 26 '16