Ask Your Question
0

raspberry pi cam node for melodic ubuntu 18.04 server

asked 2020-07-02 07:28:04 -0500

kallivalli gravatar image

updated 2020-07-03 05:12:11 -0500

hello,

I installed a fresh Ubuntu server 64-bit os with ubuntu melodic. I have raspberry pi camera v1.3, Is there any alternative of raspicam_node for melodic.

I tried to git clone raspicam_node on raspberry pi 4 but CMake error[ could not find mmal libraries ]

any suggestion what to do?

error :

image description

edit retag flag offensive close merge delete

Comments

Might help if you post the text of the error.

jordan gravatar image jordan  ( 2020-07-02 08:58:18 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2020-07-02 14:30:09 -0500

jordan gravatar image

I too had problems with raspicam_node on Pi4. So I fall back to trying to install similar to:

‘https://github.com/fpasteau/raspicam_node‘,

and

‘https://github.com/raspberrypi/userland‘

I then did the following step-by-step commands:

cd src/
git clone https://github.com/6by9/userland.git
cd userland/
git checkout 64bit_mmal
./buildme –aarch64
ls /opt/vc/bin/

raspivid
/opt/vc/bin/raspivid
find . -name libmmal_core.so

This now runs:

LD_PRELOAD=”/opt/vc/lib/libmmal_vc_client.so /opt/vc/lib/libvcsm.so /opt/vc/lib/libmmal_core.so /opt/vc/lib/libmmal_util.so” /opt/vc/bin/raspistill -o cam.jpg

Which is a step closer. After fixing the runtime errors, it works.

Enable ROS raspicam_node

To enable rapicam_node, do the following steps:

cd catkin_ws/src/
git clone https://github.com/fpasteau/raspicam_node.git raspicam
cd ..
catkin_make
source devel/setup.bash
export LD_PRELOAD=”/opt/vc/lib/libmmal_vc_client.so /opt/vc/lib/libvcsm.so /opt/vc/lib/libmmal_core.so /opt/vc/lib/libmmal_util.so”

rosrun raspicam raspicam_node _height:=1280 _width:=960

In another terminal:

rosservice call /camera/start_capture

There are more details here: https://rhoeby.com/blog/adding-ros-ra...

edit flag offensive delete link more

Comments

i had an error after ./buildme -arch64 in userland sectioninterface/khronos/CMakeFiles/khrn_client.dir/build.make:134: recipe for target 'interface/khronos/CMakeFiles/khrn_client.dir/common/khrn_int_hash_asm.s.o' failed so what to do it didnt compiled successfully

kallivalli gravatar image kallivalli  ( 2020-07-03 01:22:34 -0500 )edit

You might need to start with a fresh install of Ubuntu/ROS, as per:

https://rhoeby.com/blog/install-ros-o...

It worked for me.

jordan gravatar image jordan  ( 2020-07-03 08:11:41 -0500 )edit

I dropped the plan of using raspicam_node, instead used usb_cam now it worked

kallivalli gravatar image kallivalli  ( 2020-07-15 23:12:46 -0500 )edit

There is a typo, it should be

./buildme --aarch64

double dash Then it compiles

Wintermute gravatar image Wintermute  ( 2020-08-14 05:12:07 -0500 )edit

I get this error for every command I type in the terminal after following the instructions /usr/bin/clear_console: error while loading shared libraries: libvchiq_arm.so: cannot open shared object file: No such file or directory

I am using rasp4 with ubuntu 18.04 arm64

rezenders gravatar image rezenders  ( 2021-05-06 13:40:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-07-02 07:28:04 -0500

Seen: 1,459 times

Last updated: Jul 03 '20