Autoware Camera-LiDAR Calibration Package - saving the extrinsic calibration .yaml file

asked 2020-02-09 17:09:49 -0500

msaeUF gravatar image

updated 2020-07-08 23:59:32 -0500

jayess gravatar image

I am following the directions on: https://autoware.readthedocs.io/en/fe...

to calibrate the lidar and camera. I was able to to get the intrinsic calibration however cannot get the extrinsic calibration file. As directed, in a sourced terminal, with the correct path and image_src I run: roslaunch autoware_camera_lidar_calibrator camera_lidar_calibration.launch intrinsics_file:=/PATH/TO/YYYYmmdd_HHMM_autoware_camera_calibration.yaml image_src:=/image

This opens up a window of what my camera is seeing, and then on another terminal I open rviz and visualize the raw point cloud coming live from my Velodyne LiDAR. I then pick a point in the window that previously popped up, and then using publish point tool, pick the 3-D equivalent point in RVIZ. I do that 9+ times and the calibrator node continues to run. There is no save option or anything, how do I save the calibration? If I do ctrl+c it exits out and no file is made. The directions just say "Once finished, a file will be saved in your home directory with the name" but how do you finish? I wasn't able to find any file in the home directory.

edit retag flag offensive close merge delete

Comments

1

The parameter file should be automatically saved once you click 9 times each. If you don't see any file, that means you probably did something wrong(e.g. clicked something twice). Could you paste the output of the terminal you started the launch file?

mitsudome-r gravatar image mitsudome-r  ( 2020-02-09 20:39:53 -0500 )edit

I tried it again and it saved. Thank you. However, now I am getting in another issue. I have the extrinsic and intrinsic calibration files, but I can't get sensor fusion i.e. fusion of lidar and camera data. I used Pixel-Cloud Fusion node (https://autoware.readthedocs.io/en/fe...) but it keeps on saying waiting for intrinsic file and the target frame does not exist. Am I supposed to do something else also?
Running the calibration publisher using the extrinsic yaml file and it runs and exits out of the node - is that how it is supposed to be?

I would really appreciate if you could direct me of the next steps I could take inorder to overlay the data of each sensor and get "sensor fusion". Thank you!!

msaeUF gravatar image msaeUF  ( 2020-02-10 16:58:49 -0500 )edit

I'm working on the camera calibration in autoware.ai 1.12.0 too, can I ask you a question? I installed autoware.ai 1.12.0 and entered "rosrun autoware_camera_lidar_calibrator cameracalibrator.py --square SQUARE_SIZE --size MxN image:=/image_topic" but error occur "[rospack] Error : package 'autoware_camera_lidar_calibrator' not found" How can i run camera calibrator?

giro gravatar image giro  ( 2020-07-07 23:09:11 -0500 )edit
1

Please do not create an answer to ask another question. The best course of action is to create a new question and you can ping the original author by username if you want them to answer.

Josh Whitley gravatar image Josh Whitley  ( 2020-07-08 22:04:22 -0500 )edit
1

Please create another question if your original question has been answered.

Josh Whitley gravatar image Josh Whitley  ( 2020-07-08 22:04:49 -0500 )edit

Hi, @msaeUF is the tool working for you?

Thiago de Borba gravatar image Thiago de Borba  ( 2021-05-28 04:36:08 -0500 )edit