ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Lidar not aligning with the map during rotation

asked 2020-02-03 00:33:43 -0500

Hemanth gravatar image


When i have linear translation, my lidar points and existing map both align while my robot is moving. But, when there is a rotation. The lidar doesn't align with the map. Initially, I thought that the odometry was at fault here. I took fake odometry data that is close to perfect and the lidar is still rotating and misaligning with the map. I am happy to provide any other information. Thanks in advance!

My tf_tree: map->odom->base_link->laser

Do I need to add base_footprint somewhere?

edit retag flag offensive close merge delete


did you manage to solve this issue?

Miguel_Arriscado gravatar image Miguel_Arriscado  ( 2020-02-24 05:13:15 -0500 )edit

I have a problem like that . I use rf2o odometry .

magnetRos gravatar image magnetRos  ( 2022-12-22 02:46:54 -0500 )edit

@magnetRos in the future, please don't use the answer section if you are not providing an actual answer. Comments like this one should be added as a comment to the description.

Mike Scheutzow gravatar image Mike Scheutzow  ( 2022-12-24 07:55:03 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2022-12-24 08:14:04 -0500

Mike Scheutzow gravatar image

updated 2022-12-24 08:24:30 -0500

[This is an old question, but maybe the answer helps someone.]

This laser-scan-misalignment-in-rviz symptom can happen when the map->base_link transform is not accurate. With the transform tree you show, this can be caused by the combination of 2 issues:

  1. your robot's odometry when rotating is poor i.e. the odom->base_link transform is not accurate.

  2. there is a delay in updating the map->odom transform.

You don't say if the mis-alignment corrects itself after the robot stops moving; if it does fix itself, that is probably (2) being updated. Note that If you fix the odometry, then (2) will become a lot less noticable.

I took fake odometry data that is close to perfect and the lidar is still rotating and misaligning with the map

I'm not sure what you mean here, but if true, this implies your map->odom transform is being updated to a wrong value.

edit flag offensive delete link more

answered 2022-12-22 15:00:58 -0500

Davies Ogunsina gravatar image

try setting the fix frame to odom frame.

edit flag offensive delete link more

answered 2022-12-23 00:44:33 -0500

kacaroll gravatar image

If you're using AMCL, check your params for min rotation required to update odom-map tf via the localization node

edit flag offensive delete link more

Question Tools



Asked: 2020-02-03 00:33:43 -0500

Seen: 989 times

Last updated: Dec 24 '22