Ask Your Question
0

Invalid <param> tag (husky simulation)

asked 2018-07-15 06:25:52 -0500

Hypomania gravatar image

updated 2018-07-15 13:26:52 -0500

Hi,

I know this have been asked a few times but I have wasted 2 days trying to make this work and still no resolution. I think it's something to do with URDF which I am not very familiar with so any suggestions or help are greatly appreciated!

I am trying to install this package here: waypoint_nav, whilst following the tutorials here: tutorial

Whenever I launch roslaunch outdoor_waypoint_nav outdoor_waypoint_nav_sim.launchI get this:

roslaunch outdoor_waypoint_nav outdoor_waypoint_nav_sim.launch
... logging to /home/arthur/.ros/log/e5783a58-881f-11e8-ace3-08002758e07b/roslaunch-Doge-17757.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

xacro: Traditional processing is deprecated. Switch to --inorder processing!
To check for compatibility of your document, use option --check-order.
For more infos, see http://wiki.ros.org/xacro#Processing_Order
Undefined substitution argument urdf_extras None
when processing file: /opt/ros/kinetic/share/husky_description/urdf/husky.urdf.xacro
included from: /home/arthur/catkin_ws/src/waypoint_nav/husky_customization/husky_custom_description/urdf/custom_description.urdf.xacro
included from: /home/arthur/catkin_ws/src/waypoint_nav/husky_customization/husky_custom_gazebo/urdf/custom_description.gazebo.xacro
while processing /home/arthur/catkin_ws/src/waypoint_nav/outdoor_waypoint_nav/launch/include/gazebo.launch:
while processing /home/arthur/catkin_ws/src/waypoint_nav/husky_simulator/husky_gazebo/launch/husky_empty_world.launch:
while processing /home/arthur/catkin_ws/src/waypoint_nav/husky_simulator/husky_gazebo/launch/spawn_husky.launch:
Invalid <param> tag: Cannot load command parameter [robot_description]: command [/opt/ros/kinetic/share/xacro/xacro.py '/home/arthur/catkin_ws/src/waypoint_nav/husky_customization/husky_custom_gazebo/urdf/custom_description.gazebo.xacro'     laser_enabled:=true     ur5_enabled:=false     kinect_enabled:=false     ] returned with code [2]. 

Param xml is <param command="$(find xacro)/xacro.py '$(arg husky_gazebo_description)'     laser_enabled:=$(arg laser_enabled)     ur5_enabled:=$(arg ur5_enabled)     kinect_enabled:=$(arg kinect_enabled)     " name="robot_description"/>The traceback for the exception was written to the log file

I have looked into the launch and URDF files, I still can't find out what the problem is. Could anyone with more experience please try compiling this package and see how to launch it?

Any input is greatly appreciated!

edit retag flag offensive close merge delete

Comments

1

Can you replace the screen shot with a copy and paste of the actual text please. Images cannot be searched so are far less useful.

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2018-07-15 06:29:30 -0500 )edit
Hypomania gravatar imageHypomania ( 2018-07-15 06:40:15 -0500 )edit

Did you set the robot_description parameter?

jayess gravatar imagejayess ( 2018-07-15 11:55:29 -0500 )edit

@jayess, no, it's all pulled from github. What I don't understand is why they include husky packages in their github repo and then ask you to install all husky packages from apt-get?

Hypomania gravatar imageHypomania ( 2018-07-15 12:03:37 -0500 )edit

@Hypomania I would suggest deleting the image, as you now have redundant info in the post, and I would suggest adding to the title to indicate it is specific to the husky simulation.

adamconkey gravatar imageadamconkey ( 2018-07-15 13:08:25 -0500 )edit

I am facing the same problem with you, can you tell me the solution? Thank you!

Daniel wan gravatar imageDaniel wan ( 2019-08-28 02:43:47 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2018-07-15 12:46:31 -0500

I think there are two issues:

  1. Listen to the terminal warning and use the --inorder option for xacro. See number 12 here for what the option entails. You should therefore change the robot_description param loading in waypoint_nav/husky_simulator/husky_gazebo/launch/spawn_husky.launch to

    <param name="robot_description" 
           command="$(find xacro)/xacro '$(arg husky_gazebo_description)'
                    laser_enabled:=$(arg laser_enabled)
                    ur5_enabled:=$(arg ur5_enabled)
                    kinect_enabled:=$(arg kinect_enabled)
                    --inorder
                    " />
    
  2. If you make change (1), you'll probably then get an error saying there is no xacro macro for husky_robot. The custom_description.urdf.xacro file, for some reason unknown to me, tries to use a macro for husky_robot from the husky_description package, even though there doesn't seem to be such a macro in that package (are they maybe using a non-standard husky description?). The husky.urdf.xacro file nonetheless includes everything needed to make the robot without the macro, so you just need to comment out line 34 <xacro:husky_robot /> in waypoint_nav/husky_customization/husky_custom_description/urdf/custom_description.urdf.xacro.
edit flag offensive delete link more

Comments

Thank you a lot, I ran grep on the entire repo and the macro was only declared in two places with no further uses, no idea why it's used! Thank you :)

Hypomania gravatar imageHypomania ( 2018-07-15 13:07:21 -0500 )edit
1

My Gazebo isn't starting without the macro, rviz gives an error to the robot model, have you had any success running it?

Hypomania gravatar imageHypomania ( 2018-07-15 13:26:15 -0500 )edit
1

I don't see the robot displayed in Gazebo, but I don't think I have all dependencies installed to actually use that package. I do, however, see it successfully come up in rviz without error making only the changes I described.

adamconkey gravatar imageadamconkey ( 2018-07-15 13:40:36 -0500 )edit

My Gazebo doesn't even start, could be something to do with my VM, thank you however for your help and spotting the redundancy :)

Hypomania gravatar imageHypomania ( 2018-07-15 15:42:01 -0500 )edit

Hello, I have encountered the same problem as you. Have you solved this problem? How do you solve it?

nofear123 gravatar imagenofear123 ( 2019-01-19 06:42:34 -0500 )edit
1

@nofear123, this answer solved my problem :)

Hypomania gravatar imageHypomania ( 2019-01-19 10:59:37 -0500 )edit

worked perfectly!

Saeed Arabi gravatar imageSaeed Arabi ( 2019-07-02 11:23:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-07-15 06:25:52 -0500

Seen: 690 times

Last updated: Jul 15 '18