Ask Your Question
0

Visualise point cloud in real-time

asked 2019-08-27 03:06:53 -0500

mun gravatar image

Hi

I'm new to ROS and testing out a cheap RGBD camera. The camera has the topic /camera/depth_registered/points for xyz rgb point cloud. I'm trying to visualise it using rviz by adding a new PointCloud2 display and setting Topic to /camera/depth_registered/points. However, the display is blank even when the camera node appears to be sending messages:

  6013211 VERBOSE    [FPS] IR: 0.00 Depth: 31.01 
  7029933 VERBOSE    [FPS] IR: 0.00 Depth: 30.11 
  8010593 VERBOSE    [FPS] IR: 0.00 Depth: 29.91 
  9003788 VERBOSE    [FPS] IR: 0.00 Depth: 29.76 
 10020535 VERBOSE    [FPS] IR: 0.00 Depth: 29.76 
 11004264 VERBOSE    [FPS] IR: 0.00 Depth: 29.73 
 12027005 VERBOSE    [FPS] IR: 0.00 Depth: 29.76

Anyone know why this is the case?

image description

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2019-08-27 05:24:06 -0500

MCornelis gravatar image

Rviz shows that the fixed frame [map] does not exist. So either replace the fixed frame to the camera frame (Global Options>Fixed Frame> replace map with the name of the frame the camera is in. Alternatively you could add a tf transform from the camera to the map. This way rviz knows how to transform the data published in the frame of the camera to the map frame and can then visualize it.

edit flag offensive delete link more

Comments

I've tried selecting another value for 'Fixed Frame', but there's still not point cloud shown.

mun gravatar imagemun ( 2019-08-27 08:19:59 -0500 )edit

You need to set the fixed frame to the frame_id the rgb-d is using. Anything else and it will not be shown

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2019-08-27 09:44:30 -0500 )edit

@PeteBlackerThe3rdrostopic echo /camera/rgb/camera_info shows frame_id being camera_rgb_optical_frame and I've tried setting Global Options > Fixed Frame to camera_rgb_optical_frame. Still not point cloud though.

mun gravatar imagemun ( 2019-08-27 10:01:11 -0500 )edit
0

answered 2019-08-27 08:34:13 -0500

A_YIng gravatar image

Because the topics of camera image are already existed. Therefore, it looks like you didn't publish the frame of camera. If you are using Kinect V2, the command line of publish TF frame is: roslaunch kinect2_bridge kinect2_bridge.launch publish_tf:=true

edit flag offensive delete link more

Comments

I'm actually using the Astra Pro and launched using roslaunch astra_camera astrapro.launch.

mun gravatar imagemun ( 2019-08-27 08:40:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-08-27 03:06:53 -0500

Seen: 44 times

Last updated: Aug 27