Ask Your Question
0

cannot install/run rosbridge on raspberry pi 3

asked 2019-07-15 02:20:03 -0500

mmp52 gravatar image

updated 2019-07-15 02:44:22 -0500

gvdhoorn gravatar image

I have a Raspberry Pi 3B which has debian stretch OS and a ROS kinetic running on it. I have tried to install rosbridge_suite and rosbridge_server on it from source as with this code and I had the following error:

sudo apt install ros-kinetic-rosbridge-server ros-kinetic-rosbridge-suite
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-kinetic-rosbridge-server
E: Unable to locate package ros-kinetic-rosbridge-suite

I believe rosbridge for ROS kinetic is already available, correct me if I am mistaken. After this failed trial, I tried to build it using a rosinstall_generator as described in here , by those commands:

$ pi@raspberrypi:~/ros_catkin_ws $ rosinstall_generator rosbridge_server --rosdistro kinetic --deps --wet-only --tar > kinetic-custom_ros.rosinstall
$ pi@raspberrypi:~/ros_catkin_ws $  wstool init src kinetic-ros_comm-wet.rosinstall
Error: There already is a workspace config file .rosinstall at "src". Use wstool install/modify.
pi@raspberrypi:~/ros_catkin_ws $ wstool merge -t src kinetic-custom_ros.rosinstall
     Performing actions: 
     Add new elements:
  common_msgs/actionlib_msgs,  common_msgs/diagnostic_msgs,  common_msgs/nav_msgs,  common_msgs/sensor_msgs,  common_msgs/stereo_msgs,  common_msgs/trajectory_msgs,  common_msgs/visualization_msgs,  geometry2/tf2_msgs,  ros_tutorials/rospy_tutorials,  rosauth,  rosbag_migration_rule,  rosbridge_suite/rosapi,  rosbridge_suite/rosbridge_library,  rosbridge_suite/rosbridge_msgs,  rosbridge_suite/rosbridge_server
Config changed, maybe you need run wstool update to update SCM entries.
Overwriting /home/pi/ros_catkin_ws/src/.rosinstall*
update complete.

then I enter this:

pi@raspberrypi:~/ros_catkin_ws $  wstool update -t src

After doing this and catkin making, when I ask for rospack list to see the downloaded/built packages, I cannot see rosbridge server or rosbridge suite. Anway, afterwards I tried to run a node for rosbridge :

pi@raspberrypi:~ $ roslaunch rosbridge_server rosbridge_udp.launch

and I got the error:

[rosbridge_udp.launch] is neither a launch file in package [rosbridge_server] nor is [rosbridge_server] a launch file name
The traceback for the exception was written to the log file

Afterwards, I went to the folder in which launch file is located, and tried to run it with:

pi@raspberrypi:~/ros_catkin_ws/src/rosbridge_suite/rosbridge_server/launch $ roslaunch rosbridge_udp.launch

*****... logging to /home/pi/.ros/log/d966bdce-a4c1-11e9-b85d-b827eb727113/roslaunch-raspberrypi-4361.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.
started roslaunch server http://raspberrypi:43533/
SUMMARY
========
PARAMETERS
 * /rosapi/params_glob: [*]
 * /rosapi/services_glob: [*]
 * /rosapi/topics_glob: [*]
 * /rosbridge_udp/authenticate: False
 * /rosbridge_udp/delay_between_messages: 0
 * /rosbridge_udp/fragment_timeout: 600
 * /rosbridge_udp/interface: 
 * /rosbridge_udp/max_message_size: None
 * /rosbridge_udp/params_glob: [*]
 * /rosbridge_udp/port: 9090
 * /rosbridge_udp/services_glob: [*]
 * /rosbridge_udp/topics_glob: [*]
 * /rosbridge_udp/unregister_timeout: 10
 * /rosdistro: kinetic
 * /rosversion: 1.12.14
NODES
  /
    rosapi (rosapi/rosapi_node)
    rosbridge_udp (rosbridge_server/rosbridge_udp)
auto-starting new master
process[master]: started with pid [4372]
ROS_MASTER_URI=http://localhost:11311
setting /run_id to d966bdce-a4c1-11e9-b85d-b827eb727113
process[rosout-1]: started with pid [4385]
started core service [/rosout]
ERROR: cannot launch node of type [rosbridge_server/rosbridge_udp]: rosbridge_server
ROS path [0]=/opt/ros/kinetic/share/ros
ROS path [1]=/opt/ros/kinetic/share
ERROR: cannot launch node of type [rosapi/rosapi_node]: rosapi
ROS path [0]=/opt/ros/kinetic/share/ros
ROS path [1]=/opt/ros/kinetic/share

As you can see I cannot run the node , and I am not sure what is the reason. Thank you for your help!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-07-15 04:38:52 -0500

mmp52 gravatar image

It seems that the answer is following installation steps strictly, after adding a new package with rosinstall:

$ cd ~/ros_catkin_ws $ rosinstall_generator <your_required_ros_packages> --rosdistro kinetic --deps --wet-only --tar > kinetic-custom_ros.rosinstall $ wstool merge -t src kinetic-custom_ros.rosinstall $ wstool update -t src

One should catkin make in a special method (I was just catkin_make'ing and the package did not build in that case): $ sudo ./src/catkin/bin/catkin_make_isolated --install -DCMAKE_BUILD_TYPE=Release --install-space /opt/ros/kinetic

So this solves the installation and building any package to RosberryPi

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-07-15 02:19:34 -0500

Seen: 103 times

Last updated: Jul 15