target_frame map does not exist

asked 2019-05-30 06:52:39 -0500

aefka gravatar image

updated 2019-06-10 05:21:50 -0500

HI, I have a problem with, in my opinion, read map through move_base node.

When I launch my move_base.launch I got a WARN:

[ WARN] [1559215881.016792500, 588.765000000]: Timed out waiting for transform from base_link to map to become available before running costmap, tf error: canTransform: target_frame map does not exist.. canTransform returned after 588.765 timeout was 0.1.

But next communicats are:

[ INFO] [1559215882.172031593, 589.785000000]: Using plugin "static"
[ INFO] [1559215882.193340817, 589.801000000]: Requesting the map...
[ INFO] [1559215882.456086100, 590.027000000]: Resizing costmap to 4000 X 4000 at 0.050000 m/pix
[ INFO] [1559215882.590548878, 590.134000000]: Received a 4000 X 4000 map at 0.050000 m/pix
[ INFO] [1559215882.590664833, 590.135000000]: Subscribing to updates
[ INFO] [1559215882.608805401, 590.144000000]: Using plugin "inflation"
[ INFO] [1559215882.810460955, 590.298000000]: Using plugin "obstacles_laser"
[ INFO] [1559215882.815282109, 590.302000000]:     Subscribed to Topics: laser
[ INFO] [1559215882.876871143, 590.351000000]: Using plugin "inflation"
[ INFO] [1559215882.971461633, 590.425000000]: Created local_planner base_local_planner/TrajectoryPlannerROS
[ INFO] [1559215882.990769389, 590.442000000]: Sim period is set to 0.05
[ INFO] [1559215883.263756661, 590.676000000]: Recovery behavior will clear layer obstacles
[ INFO] [1559215883.278203387, 590.686000000]: Recovery behavior will clear layer obstacles
[ INFO] [1559215883.503132378, 590.831000000]: odom received!

In my map.yaml I have direct path to map.pgm

I do not know if this is a problem or not because:

  • When I use DWAPlannerROS and send a goal in rviz, my model isn't moving, and move_base send a communicat: DWA planner failed to produce path

  • When I use TrajectoryPlannerROS and send a goal in rviz, my model is moving, but not to a goal just somewhere on the map and smoetimes appears communicat: [ WARN] [1559217281.143489606, 1767.469000000]: Map update loop missed its desired rate of 4.0000Hz... the loop actually took 0.2680 seconds

I use p3dx model, on ROS Melodic, Ubuntu 18.04

EDIT:

costmap_common.yaml:

footprint: [[0.07, 0.19], [0.17, 0.08], [0.17, -0.08], [0.07, -0.19], [-0.07, -0.19], [-0.09, -0.16], [-0.19, -0.16], [-0.26, -0.05], [-0.26, 0.05], [-0.19, 0.16], [-0.09, 0.16], [-0.07, 0.19]]
footprint_padding: 0.01

robot_base_frame: base_link
update_frequency: 2.0
publish_frequency: 3.0
transform_tolerance: 0.5

resolution: 0.05

obstacle_range: 5.5
raytrace_range: 6.0

#layer definitions
static:
    map_topic: /map
    subscribe_to_updates: true

obstacles_laser:
    observation_sources: laser
    laser: {data_type: LaserScan, clearing: true, marking: true, topic: /p3dx/laser/scan, inf_is_valid: true}

inflation:
    inflation_radius: 1.0

costmap_local.yaml

global_frame: map
rolling_window: true

plugins:
  - {name: obstacles_laser,           type: "costmap_2d::ObstacleLayer"}
  - {name: inflation,                 type: "costmap_2d::InflationLayer"}

global_costmap.yaml

global_frame: map
rolling_window: false
track_unknown_space: true
static_map: true


plugins:
  - {name: static,                  type: "costmap_2d::StaticLayer"}
  - {name: inflation,               type: "costmap_2d::InflationLayer"}

planner.yaml

controller_frequency: 2.0
recovery_behaviour_enabled: true

NavfnROS:
  allow_unknown: true 
  default_tolerance: 0.1 

TrajectoryPlannerROS:
  # Robot Configuration Parameters
  acc_lim_x: 2.5
  acc_lim_theta:  3.2

  max_vel_x: 1.0
  min_vel_x: 0.0

  max_vel_theta: 1.0
  min_vel_theta: -1.0
  min_in_place_vel_theta: 0.2

  holonomic_robot: false
  escape_vel: -0.1

  # Goal Tolerance Parameters
  yaw_goal_tolerance ...
(more)
edit retag flag offensive close merge delete

Comments

I don't know about the first one but for:

Map update loop missed its desired rate of 4.0000Hz... the loop actually took 0.2680 seconds

I think you need to reduce the control loop speed to like 10 Hz or 2 Hz

Usui gravatar imageUsui ( 2019-06-03 19:25:02 -0500 )edit

I change to 2 Hz and warrning doesn't appear, so thank :) But I still can't reach a goal ;/

aefka gravatar imageaefka ( 2019-06-04 00:48:32 -0500 )edit

did it give anything? any error message? also have you successfully do the 2d nav button on rviz?

Usui gravatar imageUsui ( 2019-06-04 16:16:24 -0500 )edit

it would be nice if you upload your files too

Usui gravatar imageUsui ( 2019-06-09 23:03:24 -0500 )edit

I'm so sorry, i don't saw your answer. No, model is moving to the some place on the map, but not to the goal. I set goal via rviz 2DNavGoal, but I don't have any error message, model still looking for path to the goal, got to the some place (out of the path to the goal).

Okej, I upload my config files

aefka gravatar imageaefka ( 2019-06-10 05:12:34 -0500 )edit