clearpath husky emergency stop issue [closed]

asked 2018-05-20 15:45:04 -0600

aarontan gravatar image

updated 2018-05-23 08:52:05 -0600

Hello,

I have a clearpath husky a200. Recently, there has been a problem where the husky will keep activating the emergency stop during operation (see attached video). The problem used to happen maybe once in a while; however, it has gotten to a point now where we are are not able to even teleoperate the robot.

Things we've tried that didn't work:

  1. charging the battery overnight to ensure full charge
  2. checked all connections on board from sensors, estop receiver...etc
  3. charged the estop pendent to ensure full charge

Please let me know if you've seen this issue before?

https://www.youtube.com/watch?v=jW91u...

UPDATE (May 21st): I have tried installing a new ISO for the husky, still didn't fix the problem

UPDATE 2 (May 23rd): I have found that the error seems to happen less when operating at extremely low speeds and acceleration via keyboard teleoperation (teleop_twist_keyboard: this package allows the user to increase/decrease speed). This might be why joystick operation causes the error to happen immediately (the joystick commands outputs a preset high velocity/acceleration upon user input).

  1. Could there be a corrupted file somewhere in Husky that prohibits certain user vel/accel commands which subsequently stops the husky? If so, where should I look?

  2. Also, how can I lower the speed output from the joystick operation to verify that this is indeed a speed/acceleration limit issue?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by aarontan
close date 2018-06-06 13:23:14.244605

Comments

Could you clarify whether you've contacted Clearpath about this already?

gvdhoorn gravatar imagegvdhoorn ( 2018-05-21 01:50:54 -0600 )edit

yes, I have emailed tech support at clearpath but I was hoping someone whose experienced this before may help me before clearpath responds

aarontan gravatar imageaarontan ( 2018-05-21 07:32:23 -0600 )edit
aarontan gravatar imageaarontan ( 2018-05-23 11:00:59 -0600 )edit

Clearpath has confirmed that this is a hardware issue.

aarontan gravatar imageaarontan ( 2018-06-06 13:22:57 -0600 )edit