Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

clearpath husky emergency stop issue

Hello,

I have a clearpath husky a200. Recently, there has been a problem where the husky will keep activating the emergency stop during operation (see attached video). The problem used to happen maybe once in a while; however, it has gotten to a point now where we are are not able to even teleoperate the robot.

Things we've tried that didn't work:

  1. charging the battery overnight to ensure full charge
  2. checked all connections on board from sensors, estop receiver...etc
  3. charged the estop pendent to ensure full charge

Please let me know if you've seen this issue before?

https://www.youtube.com/watch?v=jW91uOJ2uwI

clearpath husky emergency stop issue

Hello,

I have a clearpath husky a200. Recently, there has been a problem where the husky will keep activating the emergency stop during operation (see attached video). The problem used to happen maybe once in a while; however, it has gotten to a point now where we are are not able to even teleoperate the robot.

Things we've tried that didn't work:

  1. charging the battery overnight to ensure full charge
  2. checked all connections on board from sensors, estop receiver...etc
  3. charged the estop pendent to ensure full charge

Please let me know if you've seen this issue before?

https://www.youtube.com/watch?v=jW91uOJ2uwI

clearpath husky emergency stop issue

Hello,

I have a clearpath husky a200. Recently, there has been a problem where the husky will keep activating the emergency stop during operation (see attached video). The problem used to happen maybe once in a while; however, it has gotten to a point now where we are are not able to even teleoperate the robot.

Things we've tried that didn't work:

  1. charging the battery overnight to ensure full charge
  2. checked all connections on board from sensors, estop receiver...etc
  3. charged the estop pendent to ensure full charge

Please let me know if you've seen this issue before?

https://www.youtube.com/watch?v=jW91uOJ2uwI

clearpath husky emergency stop issue

Hello,

I have a clearpath husky a200. Recently, there has been a problem where the husky will keep activating the emergency stop during operation (see attached video). The problem used to happen maybe once in a while; however, it has gotten to a point now where we are are not able to even teleoperate the robot.

Things we've tried that didn't work:

  1. charging the battery overnight to ensure full charge
  2. checked all connections on board from sensors, estop receiver...etc
  3. charged the estop pendent to ensure full charge

Please let me know if you've seen this issue before?

https://www.youtube.com/watch?v=jW91uOJ2uwI

UPDATE (May 21st): I have tried installing a new ISO for the husky, still didn't fix the problem

clearpath husky emergency stop issue

Hello,

I have a clearpath husky a200. Recently, there has been a problem where the husky will keep activating the emergency stop during operation (see attached video). The problem used to happen maybe once in a while; however, it has gotten to a point now where we are are not able to even teleoperate the robot.

Things we've tried that didn't work:

  1. charging the battery overnight to ensure full charge
  2. checked all connections on board from sensors, estop receiver...etc
  3. charged the estop pendent to ensure full charge

Please let me know if you've seen this issue before?

https://www.youtube.com/watch?v=jW91uOJ2uwI

UPDATE (May 21st): I have tried installing a new ISO for the husky, still didn't fix the problem

UPDATE 2 (May 23rd): I have found that the error seems to happen less when operating at extremely low speeds and acceleration via keyboard teleoperation (teleop_twist_keyboard: this package allows the user to increase/decrease speed). This might be why joystick operation causes the error to happen immediately (the joystick commands outputs a preset high velocity/acceleration upon user input).

  1. Could there be a corrupted file somewhere in Husky that prohibits certain user vel/accel commands which subsequently stops the husky? If so, where should I look?

  2. Also, how can I lower the speed output from the joystick operation to verify that this is indeed a speed/acceleration limit issue?