Ask Your Question
0

Not able to visualize Octomap in RViz

asked 2018-03-30 05:06:07 -0600

thepirate16 gravatar image

updated 2018-03-30 05:52:08 -0600

jayess gravatar image

I am publishing an octomap from a .bt file with octomap_server such that:

$ rosrun octomap_server octomap_server_node btFile.bt

But when I try to visualize the octomap in RViz, I am only getting this ┬┐occupancy base? (see image).

image description

As you see, it is clear that the transform from /map to blocks is not published. Does this need to be there to be able to visualize it? Also, it is saying that the frame blocks does not exist.

In OCTOVIS, I do not have this problem and the whole octomap is loaded successfully (see image below).

image description

How can I solve this?

edit retag flag offensive close merge delete

1 Answer

Sort by ┬╗ oldest newest most voted
0

answered 2018-04-01 13:09:36 -0600

thepirate16 gravatar image

I solved it.

Surprisingly, when I added the OccupancyMap by doing Add->By topic, it worked and the octomap appeared instantly. I am not sure if this was a refreshing-related problem. If I tried to add it in another way, the octomap was not shown.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2018-03-30 05:06:07 -0600

Seen: 414 times

Last updated: Apr 01 '18