Ask Your Question
0

opensuse 42.3 rosdep install

asked 2018-03-12 12:06:44 -0600

sancelot gravatar image

updated 2018-03-12 12:50:20 -0600

gvdhoorn gravatar image

Hi, i would like to install ros on opensuse leap 42.3

I tried using rosdep . unfortunately, I can not retrieve rosdep. the next mistake has appeared:

Could not find a version that satisfies the requirement rosdep (from versions: )
No matching distribution found for rosdep

any idea?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-03-12 12:49:22 -0600

gvdhoorn gravatar image

updated 2018-03-13 01:39:21 -0600

Officially this is not supported, but for an internal project I tried to install ros_comm on Leap some months ago. To test whether it would work I did this with Docker. See gavanderhoorn/docker_kinetic_on_opensuse_leap for the Dockerfile.

Some notes:

  1. I'm not an OpenSUSE user: I most likely did some terrible things, especially wrt package management.
  2. Apart from starting roscore, I've not tested anything, other than made sure the build completed without any serious warnings or errors.
  3. As I limited myself to ros_comm, my dependencies were relatively easy to find. I expect you'll progressively run into more and more dependency issues when you start expanding the set of ROS pkgs you include in your build
  4. No guarantees that this still works
  5. I did it in a Docker image, but if you consider the Dockerfile as a 'recipe', it would probably work on a regular system as well. I have not tested this though, and it will install ROS system wide, which is probably not such a good idea

Finally: to avoid having to build everything from source, you could consider using the official ROS Docker images instead: hub.docker.com/ros (wiki documentation). Doing it that way in general works, but gets trickier when GUI applications are involved. Here in the lab we've had quite some success using Singularity in those cases. Similar to Docker, but less isolation, which especially helps if you are not necessarily only deploying, but also developing with images and containers.


Edit: and to answer your question: if that output is from zypper, then that makes sense, as afaik none of the ROS tools has been released for OpenSUSE/RPM platforms.


Edit:

I will "Use source-installed rosdep'.

That is what the Dockerfile does as well, and you'll have to, as rosdep is not released as a binary package for your OS/platform.

From my developer viewpoint that sounds to be a safest way cloning src and compiling it.

Well, there's one big disadvantage to building things from source: there is no automated update mechanism. You are responsible for tracking upstream and making sure you keep your software up-to-date.

If you do start building things from source on your system, you might want to look into Python virtualenv.

edit flag offensive delete link more

Comments

I am interested in rviz at first. I will have a look at your work.

I finally found this thread http://wiki.ros.org/rosdep

I will "Use source-installed rosdep'. From my developer viewpoint that sounds to be a safest way cloning src and compiling it.

sancelot gravatar imagesancelot ( 2018-03-12 17:04:58 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-03-12 12:06:44 -0600

Seen: 100 times

Last updated: Mar 13 '18