Ask Your Question
0

Checksum md5sum mismatch when using Joystick

asked 2019-03-19 08:14:57 -0500

shmpwk gravatar image

Hi, I'm trying to let drone hover using motion capture system. However, it failed because of the joystick problem maybe. It seems I should ask people who made drone, and actually I did, but didn't solved. They say it might be a general ros question, so I am asking here.

The error is this.

client wants service /crazyflie/takeoff to have md5sum d41d8cd98f00b204e9800998ecf8427e, but it has b665b6c83a196e4774268cc26329b159. Dropping connection.

crazyflie is the name of the drone. When I push the button which let drone takeoff, the error occurred.

How can I fix it?

edit retag flag offensive close merge delete

Comments

Please describe your setup in more detail. I assume you have an on-board controller on the drone running ROS, as well as a Laptop/Desktop PC running ROS as well. Doublecheck that you do have the same ROS version on both systems and the same package version of the package containing the service definition.

mgruhler gravatar image mgruhler  ( 2019-03-20 02:33:02 -0500 )edit

Sorry for late replying. You're right. Just the different version problem.

shmpwk gravatar image shmpwk  ( 2020-04-28 07:21:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-04-28 07:23:50 -0500

shmpwk gravatar image

I deleted the package and tried another new package, and it works.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-03-19 08:14:57 -0500

Seen: 94 times

Last updated: Apr 28 '20