Ask Your Question
0

Remote Teleop does not work

asked 2018-02-04 12:57:59 -0500

Boregard gravatar image

updated 2018-02-11 02:36:30 -0500

Hi. I installed turtlebot 3 simulation. Now simulation of turtlebot is running on machine1:

roslaunch turtlebot3_fake turtlebot3_fake.launch

Environment variables were set before:

ROS_MASTER_URI
ROS_IP

Both pointing to IP of machine1.

On machine2 i want to start teleop to controll the bot. Environment variables were set so that Master is pointing to machine1.

The right master connection is shown after i started teleop.

roslaunch turtlebot3_teleop turtlebot3_teleop_key.launch

Teleop is running, no error shown. But nothing happens on machine1 when i hit some buttons (w,a,s,d) Robot moves if I use teleop on machine1.

RQT on machine2 seems to report correct connection and data e.g. velocity. Ping and ssh in both directions is fine.

Whats missing? Some tips? Thanks in advance for your support.

Update on details: Please find all details below:

machine1:

ip: 192.168.2.121

ROS_MASTER_URI=http://192.16.8.2.121:11311

ROS_IP=192.168.2.121

ROS_HOSTNAME not provided/set

simulation was launched:

roslaunch turtlebot3_fake turtlebot3_fake.launch

machine2:

ip: 192.168.2.122

ROS_MASTER_URI=http://192.168.2.121:11311

ROS_IP=192.168.2.122

ROS_HOSTNAME=localhost (was set by apt-get installation or something else)

teleop was started: roslaunch turtlebot3_teleop turtlebot3_teleop_key.launch

rostopic echo on machine1 does not show anything unless I start teleop on machine 1.

During start of teleop on machine2 this log is printed on the terminal:

marco@ros-pi:~$ roslaunch turtlebot3_teleop turtlebot3_teleop_key.launch
... logging to /home/marco/.ros/log/ec0d656e-0ab1-11e8-adf6-247703a699e0/roslaunch-ros-pi-9040.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://localhost:35055/

SUMMARY
========

PARAMETERS
 * /rosdistro: kinetic
 * /rosversion: 1.12.12

NODES
  /
    turtlebot3_teleop_keyboard (turtlebot3_teleop/turtlebot3_teleop_key)

ROS_MASTER_URI=http://192.168.2.121:11311

process[turtlebot3_teleop_keyboard-1]: started with pid [9049]

Control Your Turtlebot3!
---------------------------
Moving around:
        w
   a    s    d
        x

w/x : increase/decrease linear velocity
a/d : increase/decrease angular velocity
space key, s : force stop
edit retag flag offensive close merge delete

Comments

1

ROS_HOSTNAME=localhost

This is almost never a good idea. I'd remove it.

(was set by apt-get installation or something else)

That would seem doubtful, as those variables are not set by any (officical) ROS pkgs.

gvdhoorn gravatar image gvdhoorn  ( 2018-02-11 04:12:00 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-02-05 04:00:49 -0500

ski11io gravatar image

can you post an echo of your ROS_IP, MASTER_URI from both machines?

echo $ROS_MASTER_URI; echo $ROS_IP

my first assumtion would be that the ros_ip on machine 2 is not correct.

did you check if your teleop commands arrive at the correspondig topic?

rostopic echo <topic for command vel e.g. cmd_vel depends on installation>`
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-02-04 12:54:58 -0500

Seen: 823 times

Last updated: Feb 11 '18