Ask Your Question
0

hokuyo error 06->06

asked 2012-02-22 03:26:22 -0500

vivek gravatar image

updated 2014-01-28 17:11:27 -0500

ngrennan gravatar image

im using a hokuyo urg-04lx , and whenever i run hokuyo_node i get this error

Exception thrown while opening Hokuyo. timeout reached (in hokuyo::laser::laserReadline) You may find further details at http://www.ros.org/wiki/hokuyo_node/Troubleshooting

and

Laser returned abnormal status message, aborting: Trouble!! Error Code=[06->06] You may be able to find further information at http://www.ros.org/wiki/hokuyo_node/Troubleshooting/

is there any solution ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
3

answered 2012-02-22 04:28:51 -0500

Chad Rockey gravatar image

Looking at this question and the SCIP 2.0 protocol (page 11), it looks like this is the Scan Interval has non-numeric value.

Can you verify your Hokuyo still works with the Hokuyo tools? Can you hear it spinning? Is it making bad noises?

edit flag offensive delete link more

Comments

i tried reconnecting and found something odd, it kept spinning up and spinning down and again spinning up and continues this for about 6 times and then stops. i tried with hokuyo tools , but it dosent even recognise the laser. Im having a feeling that this is a hardware problem.

vivek gravatar image vivek  ( 2012-02-22 16:48:04 -0500 )edit

Sorry to hear that. :(

Chad Rockey gravatar image Chad Rockey  ( 2012-02-23 04:30:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-02-22 03:26:22 -0500

Seen: 766 times

Last updated: Feb 22 '12