Ask Your Question
1

hokuyo_node error code 15->15

asked 2011-09-08 00:32:59 -0500

p schwab gravatar image

updated 2014-01-28 17:10:21 -0500

ngrennan gravatar image

Hi,

our hokuyo laser has suddenly stopped working. On rosrun-ing hokuyo_node the following error message is displayed:

[ERROR] [1315484154.288808300]: Laser returned abnormal status message, aborting: Trouble!! Error Code=[15->15] You may be able to find further information at http://www.ros.org/wiki/hokuyo_node/Troubleshooting/

The mentioned wiki page doesn't cover our error code and mentions that these codes are undocumented. None of the offered solutions fix the error, which has been preventing us from using the hokuyo for a week now.

Does anyone know what this error code means or how to resolve this error?

Thanks in advance

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2011-09-08 01:57:56 -0500

dornhege gravatar image

updated 2011-09-08 01:58:17 -0500

The protocol definition also lists error code 15 as "Others".

So, the hokuyo worked fine and now suddenly doesn't anymore after you power cycled the Hokuyo and rebooted the system it's running on? You can also try another computer to be safe.

Unfortunately, in that case I think there is a problem with the hokuyo itself. You can try checking that the power is OK and data connection is worked. Also see if the output of dmesg shows any errors when you plug it in.

As a minimal test on the software site you can try connection with a terminal program to the device (e.g. gtkterm) and send the V command (basically V<enter>). The hokuyo should reply with version information.

edit flag offensive delete link more

Comments

Dmesg is not reporting any errors. Power is on and data connection succeeds on our windows machine - but it also can't read any data from the laser..
p schwab gravatar imagep schwab ( 2011-09-08 05:24:18 -0500 )edit
That doesn't sound so good. Does it spin up at all? You can hear that.
dornhege gravatar imagedornhege ( 2011-09-08 21:33:05 -0500 )edit
sorry for the late answer, no it didnt spin up anymore. We have kindly been lended another hokuyo from our friends in styria, and it works just fine. So to resolve this problem for other users: error code 15->15 indicates hardware failure
p schwab gravatar imagep schwab ( 2011-09-13 05:17:03 -0500 )edit
2

answered 2011-09-08 01:43:17 -0500

Hi p schwab,

You should contact to your provider or directly to Hokuyo since this seems to be a hardware problem.

If this happens when you are scanning, the Communication Protocol Specification for SCIP2.0's Table 3 of the page 15/32 says that errors from 10 to 17 are "Others" (temporary document from 4/12/2009)

Anyway, have you tried Hokuyo drivers? You can find them here: www.hokuyo-aut.co.jp/02sensor/07scanner/download/urg_programs There is a sample program that can give you some more information.

We had problems with one UTM30LX (the red light blinked instead of keep on) they had to update the firmware, but now there's a tool which you can do it by yourself.

I hope this helps you a bit.

edit flag offensive delete link more

Comments

Yes, we just tried using some of the demo applications hokuyo provides for windows - the configuration tools work fine.. however the UrgViewer which should record data from the laser is simply not doing anything, I suspect that is due to the lack of error handling in those applications.
p schwab gravatar imagep schwab ( 2011-09-08 05:21:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-08 00:32:59 -0500

Seen: 904 times

Last updated: Sep 08 '11