Ask Your Question
0

Problem running hokuyo_node

asked 2012-10-14 18:10:36 -0600

throliveira gravatar image

updated 2014-01-28 17:13:56 -0600

ngrennan gravatar image

Hey Everyone!

I've installed the hokuyo_node package and just started the hokuyo tutorials (http://www.ros.org/wiki/hokuyo_node/Tutorials/UsingTheHokuyoNode).

However, when i type this command:

$ rosrun hokuyo_node hokuyo_node

The terminal displays the following message:

timeout reached (in hokuyo::laser::laserReadline) You may find further details at http://www.ros.org/wiki/hokuyo_node/Troubleshooting

I tried to search information about this error, but haven't found anything so far. Do you have any clue about what is wrong?

I am beginner at using ROS, so please try to explain with details, if it's possible... Thanks!

edit retag flag offensive close merge delete

Comments

Hey guys!

I'm actually using a Serial-USB converter cable. When i connect Hokuyo through the cable, is not shown at the default ACM* driver, but at USB0. I tried to configure the permissions for USB0, using sudo chmod a+rw /dev/ttyUSB0. My sensor is URG-04lx.

throliveira gravatar imagethroliveira ( 2012-10-15 14:56:23 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2012-10-15 03:40:54 -0600

kszonek gravatar image

updated 2012-11-25 02:05:42 -0600

Try:

ls -l /dev/ttyACM*

maybe you have more than one device connected to your computer that uses ACM driver. If so run:

rosrun hokuyo_node hokuyo_node _port:=/dev/ttyACMx

Edit:

By default, hokuyo_node assumes that you have connected with USB, which uses ACM. As tfoote wrote in the comment:

rosrun hokuyo_node hokuyo_node _port:=/dev/ttyUSB0

should do the trick.

edit flag offensive delete link more

Comments

1

With your edit use /dev/ttyUSB0 instead of ACM0

tfoote gravatar imagetfoote ( 2012-11-24 14:18:03 -0600 )edit

hi guys i try to use hokuyo laser but when i write "rosrun hokuyo_node hokuyo_node" this error occurd" [rospack] Error: stack/package hokuyo_node not found" what can i do?

hamid gravatar imagehamid ( 2013-09-08 19:21:40 -0600 )edit
1

answered 2012-10-14 22:25:59 -0600

Lorenz gravatar image

updated 2012-10-14 22:26:18 -0600

To me it seems like you are facing communication problems. Does

  ls -l /dev/ttyACM0

show the correct permissions for the device? You need to have read and write permissions. Is the laser connected properly? Maybe try a different USB cable or something. Which laser are you using? I don't know if Hokuyo maybe has different communication protocols for different lasers.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-10-14 18:10:36 -0600

Seen: 2,260 times

Last updated: Nov 25 '12