Ask Your Question
0

How to use an USB-hokuyo-laserscanner in ros-kinetic

asked 2017-01-01 04:51:11 -0500

nico_b gravatar image

How do I use a USB-hokuyo-laserscanner in ros-kinetic? hokuyo_node seems to be working and pretty well documented (since I'm a beginner using ros, that's important for me, too), but it isn't supported for kinetic. urg_node, since it's the newer driver, should also do the job, but I've got no idea on how to use the USB and not an ethernet interface. Is it even possible? Any suggestions and help setting up (in a ros-beginner-friendly way) would be great. Thanks in advance.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2017-01-02 08:13:29 -0500

nico_b gravatar image

I just got the answer myself.

First I cloned hokuyo_node (git) into ~/catkin_ws/src. Afterwards I called catkin_make which resulted in telling me, that the driver_common package (git) is missing. Cloning this one, too, and I could run catkin_make successfully.
After sourcing ~/catkin_ws/devel/setup.bash again, I was able to call rosrun hokuyo_node hokuyo_node.

edit flag offensive delete link more
2

answered 2017-01-02 08:36:10 -0500

kmhallen gravatar image

From the wiki: The hokuyo_node package is depreciated. The urg_node package should be used for new projects.

Ethernet is only used if the ip_address parameter is set. The package defaults to the serial_port /dev/ttyACM0.

edit flag offensive delete link more

Comments

When calling rosrun urg_node urg_noderos is telling me [ERROR] [1483452523.221964309]: Unknown error connecting to Hokuyo . What am I doing wrong?
Edit: Somehow it works now. Thanks again :)

nico_b gravatar imagenico_b ( 2017-01-03 08:04:28 -0500 )edit

After restarting my system today, it won't work again... Last thing I did yesterday was restarting the system to check whether it works after restart and it did... Why is my sensor not connected today? :(
Btw: Same error as in the post above...

nico_b gravatar imagenico_b ( 2017-01-04 04:10:47 -0500 )edit

I found out, I first have to run hokuyo_node. After that some bit (I don't know yet...) is set and therefore I'm able running the urg_node... Any ideas anyone?

nico_b gravatar imagenico_b ( 2017-01-05 06:15:23 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2017-01-01 04:51:11 -0500

Seen: 2,705 times

Last updated: Jan 02 '17