Ask Your Question
1

hokuyo UTM-30LX-EW laser scanner: problems to detect

asked 2015-06-30 02:52:19 -0500

enri gravatar image

Hi guys I'm having problems to detect hokuyo UTM-30LX-EW Laser Scanner. I followed the guide installation on wikiros and first I installed the hokuyo_node (actually I tried also with other package, urg_node). The problem is in the second step: I insert the Ethernet cable and when I search the laser into dev/ I don't find it. I found dev/tty0, dev/ttyS0 etc.. but not dev/ttyACM0 as is described in the guide. How I can detect the laser?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-06-30 07:33:40 -0500

fherrero gravatar image

updated 2015-07-01 03:44:24 -0500

With the Hokuyo UTM-30LX-EW connected through ethernet, you can use the urg_node, setting the ip_address parameter value. Default factory Hokuyos come with IP 192.168.0.10.

rosrun urg_node urg_node _ip_address:=192.168.0.10

-- Edit 1:

PC and laser must be on the same net 192.168.0.XX. Then, you should be able to ping the laser first,

ping 192.168.0.10

-- Edit 2:

If it does not work on a PC with IP 192.168.0.XX, maybe your Hokuyo laser has a different IP address.

To be sure, you can reset the laser IP address to the default one (192.168.0.10), following the instructions from the Laser specification (last page, section 9 - Ethernet settings - IP Initialization ), provided at the Hokuyo webpage.

If you manage to make it work with the default IP address but then you need to work in a different sub net, in the Hokuyo webpage there is a tool (for Windows) to change the laser IP address.

edit flag offensive delete link more

Comments

[ERROR] [1435675488.414973920]: Error connecting to Hokuyo: Could not open network Hokuyo: 192.168.0.10:10940 could not open ethernet port.

this is what the command returns

enri gravatar image enri  ( 2015-06-30 09:44:12 -0500 )edit

Reading this question, they basically say your computer and the laser must be on the same net (192.168.0.XX).

fherrero gravatar image fherrero  ( 2015-06-30 10:29:22 -0500 )edit

Unfortunately I cannot fix that problem, I have already read all the post that I found. This afternoon I try with this other guide: [ http://dasl.mem.drexel.edu/wiki/index... ] In this guide I don't change the IP!

thanks fherrero for the help!

enri gravatar image enri  ( 2015-07-01 02:39:57 -0500 )edit

That guide looks a bit old (ubuntu 10 and ROS Fuerte). I recommend you to reset the laser IP address (see Edit 2 of my answer) and continue trying with urg_node

fherrero gravatar image fherrero  ( 2015-07-01 03:36:48 -0500 )edit

Thanks fherrero for the advices, Finally it works!! I had to initialize it manually!

enri gravatar image enri  ( 2015-07-03 02:08:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-30 02:52:19 -0500

Seen: 2,483 times

Last updated: Jul 01 '15