Ask Your Question
0

Hokuyo_node for hydro

asked 2014-07-29 03:35:28 -0500

Moda gravatar image

I'm using ros_hydro and I need to run the hokuyo_node I tried to install the urge_node sudo apt-get install ros-hydro-urg-node And then when i launch rosrun urg_node urg_node It says : Error: stack/package urg_node not found

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-07-30 00:18:10 -0500

Ken_in_JAPAN gravatar image

updated 2014-07-31 19:17:42 -0500

Could you check if there is urg_node in /opt/ros/hydro/share with a command roscd urg_node? I guess that urg_node is not installed yet. At installing it, you might look at an error message. If you look at error message like E: Could not open lock file ~ and E:Unable to lock directory ~, you should use sudo apt-get update. Please pay attention to input with sudo.

edit flag offensive delete link more

Comments

I just installed ros-hydro-urg-node without any issues. You may need to run sudo apt-get update before installing.

mjcarroll gravatar imagemjcarroll ( 2014-07-30 07:56:30 -0500 )edit

I did sudo apt-get update! Today, I tried to install ros-hydro-urg-node with sudo apt-get install ros-hydro-urg-node again. I could do that. I guess that it's the problem of network environment in my case. At my apartment, I couldn't do,but at my lab I could do that.

Ken_in_JAPAN gravatar imageKen_in_JAPAN ( 2014-07-30 11:24:03 -0500 )edit

I'm sorry, @mjcarroll. you might be right. I might have executed apt-get update withoutsudo.

Ken_in_JAPAN gravatar imageKen_in_JAPAN ( 2014-07-31 19:12:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-29 03:35:28 -0500

Seen: 644 times

Last updated: Jul 31 '14