Ask Your Question
0

Turtlebot not moving

asked 2018-01-09 03:19:01 -0500

uclaxx99 gravatar image

updated 2018-01-10 01:07:23 -0500

I'm a newbie and running Indigo on Ubuntu 14.04, gazebo 2.2.3. I'm working on the tutorial and got some errors.

Command

$ roslaunch turtlebot_gazebo turtlebot_world.launch

Here are errors.

 [FATAL] [1515488958.125011231, 0.130000000]: Failed to load nodelet '/cmd_vel_mux` of type `yocs_cmd_vel_mux/CmdVelMuxNodelet` to manager `mobile_base_nodelet_manager'
    [FATAL] [1515488958.139058732, 0.140000000]: Failed to load nodelet '/depthimage_to_laserscan` of type `depthimage_to_laserscan/DepthImageToLaserScanNodelet` to manager `laserscan_nodelet_manager'

gazebo gui shows up but turtlebot won't move.

Can anyone tell me what went wrong?

edit retag flag offensive close merge delete

Comments

What is this a duplicate of?

It seems like you resolved your own question. Would accepting your own answer not be better in that case?

gvdhoorn gravatar image gvdhoorn  ( 2018-01-10 02:40:12 -0500 )edit

Sorry my mistake. As you suggest, I'd like to change the reason. but I can't reopen for short points.

uclaxx99 gravatar image uclaxx99  ( 2018-01-10 03:19:35 -0500 )edit

I've just re-opened it for you.

No need to 'change the reason': just tick the checkmark to the left of your own answer to answer your own question.

We don't close questions here on ROS Answers if they have an answer.

gvdhoorn gravatar image gvdhoorn  ( 2018-01-10 03:31:08 -0500 )edit

Thank you gvdhoorn! I did it but I got another error..

10 points required to accept or unaccept your own answer

uclaxx99 gravatar image uclaxx99  ( 2018-01-10 03:42:48 -0500 )edit

I've accepted it for you.

gvdhoorn gravatar image gvdhoorn  ( 2018-01-10 03:43:39 -0500 )edit

thank you!

uclaxx99 gravatar image uclaxx99  ( 2018-01-10 17:48:34 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-01-10 01:07:14 -0500

uclaxx99 gravatar image

I've found a solution by myself. Here's what I did.

Command

sudo apt-get install ros-indigo-yocs*

Now it looks fine.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2018-01-09 03:19:01 -0500

Seen: 881 times

Last updated: Jan 10 '18