Ask Your Question
0

How can I install unique_identifier package?

asked 2016-03-03 00:27:08 -0600

Reza1984 gravatar image

Hi all,

I want to install turtlebot based on the instructions stated here "http://wiki.ros.org/turtlebot/Tutorials/indigo/Turtlebot%20Installation", (section 2.3.2).

However, when I want to catkin_make rocon I get this Error "Messages depends on unknown pkg: uuid_msgs (Missing find_package(uuid_msgs?))".

Unfortunately, "sudo apt-get install ros-indigo-uuid_msgs" or "sudo apt-get install ros-indigo-unique_identifier" give Unable to locate package ros-indigo...

I appreciate if you can help me.

Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2016-03-03 01:00:16 -0600

mgruhler gravatar image

updated 2016-03-03 01:32:49 -0600

uuid_msgs is released into ROS Indigo.

You have the install command wrong. This needs to be:

sudo apt-get install ros-indigo-uuid-msgs ros-indigo-unique-identifier

Note that all underscores (_) have been replaced by dashes (-)!

You can also install all specified (i.e. it depends on the package.xmls being correct) dependencies via:

rosdep install --from-paths <catkin_ws/src> -i

EDIT

You need to have your sources set up correctly. Follow the instructions on the ROS wiki, especially 1.1-1.3, and then do a sudo apt-get update.

If you can then tab-complete the ros-indigo-... part of the install command, everything will work fine. If not, you probably still haven't set this up correctly

edit flag offensive delete link more

Comments

Thanks for your reply. Again I get same error as: E: Unable to locate package ros-indigo-uuid-msgs E: Unable to locate package ros-indigo-unique-identifier

Reza1984 gravatar imageReza1984 ( 2016-03-03 01:21:23 -0600 )edit

see edit above.

mgruhler gravatar imagemgruhler ( 2016-03-03 01:32:59 -0600 )edit

I should say that I have already tried sudo apt-get update.

Reza1984 gravatar imageReza1984 ( 2016-03-03 01:33:01 -0600 )edit

The "rosdep install --from-paths ~/catkin_ws/src -i" gives me "#All required rosdeps installed successfully"

Reza1984 gravatar imageReza1984 ( 2016-03-03 01:34:10 -0600 )edit

Ok I try to check if the sources set up correctly or not. Thanks again

Reza1984 gravatar imageReza1984 ( 2016-03-03 01:37:14 -0600 )edit

Is ~/catkin_ws/src your workspace? This obviously needs to be replaced with the directory where you cloned the other sources. Can you post (edit your question), the contents of /etc/apt/sources.list.d/ros-latest.list?

mgruhler gravatar imagemgruhler ( 2016-03-03 01:37:14 -0600 )edit

Thanks a lot, I tried to source the set up again and used "sudo apt-get update --fix- missing". I could install. But it's strange as before that package I could install navigation package without any problem!

Reza1984 gravatar imageReza1984 ( 2016-03-03 02:00:02 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-03-03 00:27:08 -0600

Seen: 725 times

Last updated: Mar 03 '16